Bug 118422 - The keyboard shortcut to view the data sources doesn't work on the MAC
Summary: The keyboard shortcut to view the data sources doesn't work on the MAC
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: Other Mac OS X (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Mac
  Show dependency treegraph
 
Reported: 2018-06-27 17:58 UTC by Hans Gerstenkorn
Modified: 2018-07-12 14:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of shortcut key at the context menu (212.31 KB, image/png)
2018-06-27 18:00 UTC, Hans Gerstenkorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Gerstenkorn 2018-06-27 17:58:29 UTC
Description:
The keyboard shortcut (shift + command key + F4 - please see also screenshot)to view the data sources doesn't work on the MAC, per click with the mouse it works perfect 

Steps to Reproduce:
1.press the key combination
2.
3.

Actual Results:
press the key combination

Expected Results:
nothing


Reproducible: Always


User Profile Reset: No



Additional Info:
if I'm clicking the menu "view/data sources" it works.

LO:
Version: 6.0.2.1
Build-ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU-Threads: 8; BS: Mac OS X 10.13.5; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

MacBook Pro
Mac OS High Sierra 10.13.5 (17F77)
Comment 1 Hans Gerstenkorn 2018-06-27 18:00:40 UTC
Created attachment 143173 [details]
Screenshot of shortcut key at the context menu
Comment 2 Alex Thurgood 2018-07-09 07:22:47 UTC
@Hans: this works for me on an Apple bluetooth keyboard (FR locale) with the key combo:

Shift-Fn-Cmd-F4

Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Threads CPU : 4; OS : Mac OS X 10.13.5; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

As the function key press is required anyway to access the function keys on my keyboard, I don't consider this to be a bug - a pain in the backside, yes, but not a bug.

/RANT ON /
UX : sorry, people, but you really should try this for yourselves before changing stuff like this. This is significantly slower than the previous F4 shortcut and for physically impaired users this shortcut has now become a nightmare.
/RANT OFF/
Comment 3 Hans Gerstenkorn 2018-07-09 21:20:58 UTC
o.k, Alex, within Your key "Shift-Fn-Cmd-F4" it works also, but I'm with You, that ist not the same as like the window - version....

Now I'll use for simple working my mouse, and what shall I do, close this bug, it's for me an bug....

greetings :-) Hans
Comment 4 Alex Thurgood 2018-07-12 12:03:53 UTC
@Hans : I've already marked it as resolved works for me.

The F4 key on Macs equipped with Mac keyboards (Macbooks, iMac with Apple wireless keyboard, etc) brings up the OSX App launchpad - this is a system default.

In order to use the function key, you need to press the Fn key as well.

So, this is not a bug, as the prescribed LO shortcut actually requires you to activate the function key - the fact that this requires a user to press the Fn key is Apple's design choice. On Windows this isn't necessary for most computer PC keyboards, however, I have the same requirement on my Linux laptop (Dell) in order to get the function keys to work as intended, otherwise they activate some other built-in function.

One might quibble whether the LO documentation or tooltip should be adjusted to take account of this OS and keyboard specific difference, but generally the documentation does (although the tooltip not necessarily so). In that case, you could always open up a bug report against the documentation for the shortcut.
Comment 5 Hans Gerstenkorn 2018-07-12 14:43:58 UTC
Hello Alex,
I can understand your explanation very well, thank you very much for that. Unfortunately, I'm not so deep in this matter, then I wouldn't have reported as a bug ....

Best regards :-) Hans