Bug 118458 - FILEOPEN PPTX Columns don’t appear in the text box in Impress
Summary: FILEOPEN PPTX Columns don’t appear in the text box in Impress
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.2.0
Keywords: filter:pptx
: 120297 136784 140852 (view as bug list)
Depends on:
Blocks: PPTX-Textbox Textbox-column
  Show dependency treegraph
 
Reported: 2018-06-29 15:32 UTC by Gabor Kelemen (allotropia)
Modified: 2022-03-21 16:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Powerpoint (70.94 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-06-29 15:32 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the original document side by side in PowerPoint and Impress. (272.99 KB, image/png)
2018-06-29 15:32 UTC, Gabor Kelemen (allotropia)
Details
Screenshot in current 6.2 master and PP 2013 (131.40 KB, image/png)
2018-11-06 09:49 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2018-06-29 15:32:05 UTC
Created attachment 143207 [details]
Example file from Powerpoint

If we create a presentation with Microsoft PowerPoint 2010 and we insert a text box on the slide, after we type text and create columns, then the text will appear without columns in Impress.

Steps to reproduce:
1.	Create a new document in Microsoft PowerPoint 2010.
2.	Insert a text box.
3.	Type text and set the style of the text to two or more columns.
4.	Save the file as PPTX.
5.	Open the same file in LibreOffice Impress.
6.	Compare the original file opened in PowerPoint and Impress.

Actual results: The document has one column text in Impress.

Expected results: The text should preserve the original two columns.

LibreOffice details:
Version: 6.2.0.0.alpha0+
Build Id: fb8e6a6f44839f09fcd19dc500db33232bc4e15a
CPU threads: 4; OS: Windows 6.1; UI render: default;
TinderBox: Win-x86@42, Branc:master, Time: 2018-06-11_01:15:16
Locale: hu-HU (hu_HU); Calc: group threaded
Comment 1 Gabor Kelemen (allotropia) 2018-06-29 15:32:35 UTC
Created attachment 143208 [details]
Screenshot of the original document side by side in PowerPoint and Impress.
Comment 2 Gabor Kelemen (allotropia) 2018-06-29 15:38:04 UTC
This was found by my teams members.
Comment 3 Xisco Faulí 2018-07-02 22:40:17 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 Gabor Kelemen (allotropia) 2018-11-06 09:49:45 UTC
Created attachment 146345 [details]
Screenshot in current 6.2 master and PP 2013

Much improved appearance at first import.
Still: the size of the text area is not the same (larger), also when deleting text from the first column, the end of the text is moved to the first column in PP, but not in Impress.
Comment 5 Buovjaga 2019-09-29 17:49:58 UTC
Still confirmed comment 4

Version: 6.4.0.0.alpha0+ (x64)
Build ID: d744838991594eebe27acc4c7d9fb4579d654853
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-29_05:12:00
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 6 Commit Notification 2021-06-08 12:53:12 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/486a11ad6fdae1714200229462b69f328be06b5a

editengine-columns: PPTX support (tdf#118458)

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Mike Kaganski 2021-06-08 14:55:38 UTC
It's now available in all modules, also in Calc and Writer. (FTR: Excel also allows multi-column text in text boxes; Word - at least 2016 - does not.)
Comment 8 NISZ LibreOffice Team 2021-06-09 12:01:14 UTC
*** Bug 140852 has been marked as a duplicate of this bug. ***
Comment 9 NISZ LibreOffice Team 2021-06-09 12:05:59 UTC
*** Bug 120297 has been marked as a duplicate of this bug. ***
Comment 10 NISZ LibreOffice Team 2021-06-09 12:31:01 UTC
*** Bug 136784 has been marked as a duplicate of this bug. ***
Comment 11 NISZ LibreOffice Team 2021-06-10 12:49:03 UTC
Verified in:
Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: aa9cb8e14749e7fb7a83b55a2bb095501f731a18
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded