Download it now!
Bug 118489 - Fileopen: page area different in MSO and LO for DOCX with negative top and bottom margins
Summary: Fileopen: page area different in MSO and LO for DOCX with negative top and bo...
Status: RESOLVED DUPLICATE of bug 119952
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Page
  Show dependency treegraph
 
Reported: 2018-07-01 17:01 UTC by Roeland
Modified: 2019-09-17 16:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roeland 2018-07-01 17:01:05 UTC
Description:
This is the second report connected to bug 118460, which will be split up in several issues in order to focus on the different problems.


In this case Margins are not respected at all - in particular at the bottom, in MS Office there is no overlap into the footer (and beyond) while in LibreOffice text from the body overlaps footer/margin area substantially

I tried to search for similar reports, but it is very difficult to know if another bug report has the same underlying cause.

Documents to illustrate the problem:

attachment 143211 [details]
Problematic Document

attachment 143212 [details]
LibreOffice PDF Export

attachment 143213 [details] 
MS Office PDF Print

Steps to Reproduce:
1. Open attached document in LibreOffice and MS Office
2. Compare the points listed in the description


Actual Results:
See description

Expected Results:
margins are not preserved


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Justin L 2018-07-25 13:24:34 UTC
warning: this is a really goofy document. I can't even figure out how it was built in Word.

negative page margins are probably the problem here.
Comment 2 QA Administrators 2019-07-30 03:15:32 UTC Comment hidden (obsolete)
Comment 3 Timur 2019-09-17 14:19:16 UTC
attachment 154230 [details] is simplified DOCX.
Page area is different in MSO and LO for DOCX with negative top and bottom margins.
It's like MSO doesn't respect negative margins and LO does.
Comment 4 Timur 2019-09-17 14:24:34 UTC

*** This bug has been marked as a duplicate of bug 119952 ***
Comment 5 Timur 2019-09-17 14:25:49 UTC
attachment 154231 [details] is Example DOCX compared in MSO and LO