Bug Hunting Session
Bug 118520 - Layout of the insert sheet dialog is off (not in gtk3)
Summary: Layout of the insert sheet dialog is off (not in gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.0.2
Keywords: bibisected, bisected, regression
: 118811 (view as bug list)
Depends on:
Blocks: Dialog Sheet
  Show dependency treegraph
 
Reported: 2018-07-03 10:30 UTC by Telesto
Modified: 2018-07-19 15:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (5.93 KB, image/png)
2018-07-03 10:31 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-07-03 10:30:45 UTC
Description:
Layout of the insert sheet dialog is off

Steps to Reproduce:
1. Open Calc
2. Sheet -> Insert Sheet

Actual Results:
Screenshot

Expected Results:
Old look


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: bb1d5780226bb1b9156580972eea9aa849178742
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-03_05:56:48
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-07-03 10:31:21 UTC
Created attachment 143284 [details]
Screenshot
Comment 2 Xavier Van Wijmeersch 2018-07-03 12:20:10 UTC
confirm also on linux

Version: 6.2.0.0.alpha0+
Build ID: 7696d1d217b6cff63490e7f98403d0e499c33d17
CPU threads: 2; OS: Linux 4.14; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-06-30_03:32:29
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 3 Xisco Faulí 2018-07-04 13:05:35 UTC
Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2018-05-18 09:09:30 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-05-18 11:52:46 +0200
commit	a0c15b39cb30736e04564420f55c50fefb51e41a (patch)
tree	39857ed2c93dcec9af009b908271d1f2ac1e3bf3
parent	767188fd1b1e1f504864f9489076283ebc413625 (diff)
weld ScInsertTableDlg

Bisected with: bibisect-linux64-6.1

Adding Cc: to Caolán McNamara
Comment 4 Xisco Faulí 2018-07-17 20:11:46 UTC
*** Bug 118811 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2018-07-18 14:13:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56453842ddefc7cb53272cee94ebaf8a6a0d9fea

Resolves: tdf#118520 insert sheet list not horizontally expanded

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2018-07-18 14:18:24 UTC
backport to 6-1 in gerrit
Comment 7 Commit Notification 2018-07-18 18:56:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1eb8837f8410c48661fd99253faf6c8fa05353de&h=libreoffice-6-1

Resolves: tdf#118520 insert sheet list not horizontally expanded

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xavier Van Wijmeersch 2018-07-19 15:58:06 UTC
thx verified and fixed

Version: 6.2.0.0.alpha0+
Build ID: a8e657e9d04f908388580039a0ac5b9348dfee60
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded