Bug Hunting Session
Bug 118531 - recent symbols not applied as bullet item
Summary: recent symbols not applied as bullet item
Status: RESOLVED DUPLICATE of bug 113860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-03 23:10 UTC by muso
Modified: 2018-07-18 11:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of the dialog with the character list (143.12 KB, image/jpeg)
2018-07-03 23:10 UTC, muso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description muso 2018-07-03 23:10:58 UTC
Created attachment 143298 [details]
screenshot of the dialog with the character list

- open the master view
- click into an item list
- in the sidebar select "More Bullets" to specify the item symbol
- in the appearing dialog go to the tab Custom and press there the button Select
- choose there a recent character (if the recent char list is empty for you, apply first a char elsewhere to get the list filled)

result: the chosen character is not applied. In fact the default character remains so as if one never set anything
Comment 1 muso 2018-07-03 23:12:50 UTC
Comment on attachment 143298 [details]
screenshot of the dialog with the character list

In this case the default character is the black circle. I selected the Z character from the recent characters list but it is not applied.
Comment 2 Buovjaga 2018-07-15 15:41:08 UTC

*** This bug has been marked as a duplicate of bug 113860 ***
Comment 3 muso 2018-07-17 00:31:37 UTC
> *** This bug has been marked as a duplicate of bug 113860 ***
This is no dupe of 113860 because 113860 was fixed in LO 6.0.0, but the bug I described here is in LO 6.0.5.
Comment 4 Buovjaga 2018-07-17 09:17:18 UTC
Yep, but it works for me in master. Apparently there was some glitch in the automatic commit message and the whiteboard was corrected later to "target:6.1.0". Please try with 6.1 or master.
Comment 5 Xisco Faulí 2018-07-17 15:27:59 UTC
Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
Comment 6 muso 2018-07-18 11:21:23 UTC
> Please try with 6.1 or master

I don't understand your workflow. I am just a user. I am only allowed to use final releases for real-life documents. LO 6.0.5 is the most recent released version and the bug I reported is there. I reported it to get it fixed for the next bugfix release because other users should benefit from the fix as soon as possible.

However, I tried now 6.1RC1 and there the bug is indeed fixed. Unfortunately in 6.1 there is this regression bug 118531.
Comment 7 muso 2018-07-18 11:22:46 UTC
Sorry I mean:

However, I tried now 6.1RC1 and there the bug is indeed fixed. Unfortunately in 6.1 there is this regression bug 118818.
Comment 8 Buovjaga 2018-07-18 11:25:50 UTC
Yeah, I'm just a user, too. Not all bug fixes get to all living branches, it depends on the developer's willingness to backport.
Comment 9 muso 2018-07-18 11:29:44 UTC
(In reply to Buovjaga from comment #8)
> Not all bug fixes get to all living branches, it
> depends on the developer's willingness to backport.

This is a strange policy. In the OpenSource project where I develop we try to backport every fix.

At least please leave bugreports open until the fix is in the latest released version. This bug is only fixed in LO 6.1, thus please leave this bug open until 6.1 is out or until it was backported to 6.0.x. This helps bug reporters a lot to avoid to create another bug report for existing bugs.
Comment 10 Buovjaga 2018-07-18 11:32:44 UTC
Status change was a mistake, obviously still belongs as dupe. Leave a comment requesting a backport to the older report, but please do not mess with the status.

*** This bug has been marked as a duplicate of bug 113860 ***