Download it now!
Bug 118532 - [PDF-EXPORT] PNG images are stretched horizontally in exported PDF file if OpenGL is enabled
Summary: [PDF-EXPORT] PNG images are stretched horizontally in exported PDF file if Op...
Status: RESOLVED DUPLICATE of bug 121615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-04 07:02 UTC by Thomas Lendo
Modified: 2019-03-28 10:21 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Example Writer document with png and jpg images (20.22 KB, application/vnd.oasis.opendocument.text)
2018-07-04 07:02 UTC, Thomas Lendo
Details
PDF export of example file with activated OpenGL: the 2 PNG images are streched to the right side of the page (10.88 KB, application/pdf)
2018-07-04 07:03 UTC, Thomas Lendo
Details
PDF export of example file with deactivated OpenGL: all images have the correct height/width ratio (11.48 KB, application/pdf)
2018-07-04 07:04 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Lendo 2018-07-04 07:02:15 UTC
Created attachment 143300 [details]
Example Writer document with png and jpg images

PNG images are stretched horizontally when exported in a PDF file and if OpenGL is enabled.

Tested with older LibreOffice documents and with the attached one that was created with version 6.2 alpha0.

Seems to have the same cause as described in bug 116365 comment 8.

Tested with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 5fce97a58b8f764e35bf98128591c9a89537da05
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-02_23:04:53
Locale: de-AT (de_AT); Calc: CL
Comment 1 Thomas Lendo 2018-07-04 07:03:17 UTC
Created attachment 143301 [details]
PDF export of example file with activated OpenGL: the 2 PNG images are streched to the right side of the page
Comment 2 Thomas Lendo 2018-07-04 07:04:48 UTC
Created attachment 143302 [details]
PDF export of example file with deactivated OpenGL: all images have the correct height/width ratio
Comment 3 Mike Kaganski 2018-07-04 07:19:59 UTC

*** This bug has been marked as a duplicate of bug 106311 ***
Comment 4 Timur 2019-03-28 10:21:19 UTC

*** This bug has been marked as a duplicate of bug 121615 ***