Bug 118539 - There isn't Recent Characters Toolbar Dropdown Control on toolbar by default
Summary: There isn't Recent Characters Toolbar Dropdown Control on toolbar by default
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta2+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2018-07-04 17:48 UTC by Roman Kuznetsov
Modified: 2018-07-26 13:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Result of my survey about this widget (40.73 KB, image/png)
2018-07-12 14:46 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-07-04 17:48:17 UTC
Description:
There isn't Recent Charaters Toolbar Dropdown Control on toolbar (that was made by Akshay Deep  https://cgit.freedesktop.org/libreoffice/core/commit/?id=800ac37021e3f8859a52c5eebca261a5d3bc5a11) by default in Writer and in Calc.
Instead it  there is old icon Insert Special Character on toolbar.
IMHO it is regression

Steps to Reproduce:
1. Start Writer or Calc with clean user profile
2. Look at toolbar and old icon instead new Recent Charaters Toolbar Dropdown Control
3.

Actual Results:
there is old icon Insert Special Character on toolbar

Expected Results:
There is Recent Charaters Toolbar Dropdown Control on toolbar by default


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Roman Kuznetsov 2018-07-04 17:49:15 UTC
Version: 6.1.0.0.beta2+ (x64)
Build ID: 33b7319e2e08812a2f7d3126e4b1ec90875d6165
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-1, Time: 2018-07-03_04:13:19
Locale: ru-RU (ru_RU); Calc: CL
Comment 2 Roman Kuznetsov 2018-07-04 18:18:18 UTC
result of bibicest for Writer:

dc1890909d6d87abc9afff368bfa8a6b68bd7723 is the first bad commit
commit dc1890909d6d87abc9afff368bfa8a6b68bd7723
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Dec 20 17:06:19 2017 -0800

    source sha:490287a1b22411f4ac32127c93228e06dad4ff22


https://cgit.freedesktop.org/libreoffice/core/commit/?id=490287a1b22411f4ac32127c93228e06dad4ff22 by Yousuf
Comment 3 Heiko Tietze 2018-07-05 08:22:31 UTC
It was a decision by the design team to keep the old item there, mainly because of horizontal space. I wasn't conform with the decision.

(No need to bother Akshay with that; you can easily configure the toolbar yourself)
Comment 4 Heiko Tietze 2018-07-05 08:25:55 UTC
http://document-foundation-mail-archive.969070.n3.nabble.com/Libreoffice-qa-Minutes-from-the-design-meeting-2018-Jan-03-tc4230148.html

 * Toolbar button for Special characters
   + https://gerrit.libreoffice.org/#/c/46878/
   + https://gerrit.libreoffice.org/#/c/46757/2
   + New floating widget with quick access to recent/favorites (Heiko)
     or small button only that just opens the dialog (Jay)
   + don't mind (Consgor, Stuart)
   + Notebookbars provide the new widget (Jay)
   => old standard toolbar will be used
Comment 5 Roman Kuznetsov 2018-07-05 13:20:36 UTC
I consider this to be a bug. I insist on this!

Because we made cool feature and do not show it to anyone by default. IMHO, Yousuf was don't right.

I offer make a survey about this.

>you can easily configure the toolbar yourself

I can, because I know about this feature! But 99% of users don't read release notes and never customize theyr GUI.
Comment 6 V Stuart Foote 2018-07-05 13:47:10 UTC
No! It went through the UX process. Was voted down with reasonable discussion, having split button AND the static dialog launcher was deemed unnecessary default GUI. It remains available to customize.

The split Button for the UNO action (listed as a "Symbol" entry) can be activated by Function checkbox on the Customize -> Toolbars -> Standard target.

Or it can be added to any toolbar or context menu (though use on a Context menu seems wonky).

Point is--there is a default GUI, it simply does not include the second dialog holding the "Favorites & Recents" picker. Users can add it if they want to customize. No different than any other optional feature.

=> NAB and => WF
Comment 7 Roman Kuznetsov 2018-07-05 16:41:13 UTC
I'll reopen this bug until you gays ban me forever. 

A decision about using old icon was made by ONE person, because other people did not care.

Why do we make LibreOffice worse? I don't understand...
Comment 8 V Stuart Foote 2018-07-05 16:49:01 UTC
I have no issue with reworking the split button and assigning both controls to it--opening the Recent & Favorites dialog, or the Special Character dialog from the split.

I, and Jay, objected to having both active the Standard toolbar--and why it was hidden but left available in the customization.
Comment 9 Roman Kuznetsov 2018-07-12 14:46:18 UTC Comment hidden (no-value)
Comment 10 Heiko Tietze 2018-07-26 08:13:46 UTC
We discussed the topic in the design meeting and agreed unanimously (at least all who where in the meeting) to switch from the old to the new button.
Comment 11 Commit Notification 2018-07-26 13:34:07 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=350dd849194fe793e07c7080a95abf6cb97cf859

tdf#118539 - Recent Characters Toolbar Dropdown Control on toolbar

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.