Download it now!
Bug 118560 - Word Count does not change after Writer document edits
Summary: Word Count does not change after Writer document edits
Status: RESOLVED DUPLICATE of bug 116208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-05 19:56 UTC by mikemckibbin
Modified: 2018-07-06 16:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikemckibbin 2018-07-05 19:56:20 UTC
Description:
Whenever I open a new or existing file in Writer, the Word Count at the bottom of the screen never changes. Whether I type content or edit out words, it never changes. This has been the case for the last several months and the only work around I found was to assign an F# to the Word Count option, which pops open the correct word count and does reflect any changes.
I recently installed a fresh version of Windows 10 on my PC for this and other reasons but the issue remains.

Steps to Reproduce:
1.Open new or existing Writer document.
2.Type or delete several words.
3.Check Word Count at bottom of screen for any changes, use Word Count option (I assigned an F# to easily open it) to view changes in count.

Actual Results:
See above. It's pretty basic.

Expected Results:
See above. Word Count does not change.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
See above. Word Count should reflect changes in every document.
Comment 1 Jacques Guilleron 2018-07-05 21:52:54 UTC
Hi mikemckibbin,

I don't reproduce on Windows 7.
There are two places where we find thoses stats: the first is Tools > statisticrs and the second is File > Propertics: Statistics tab. Counts are theys working there? If yes, can you restart LO with a new profile or use "Restart in safe mode..." in Help menu, which is equivalent to see if that produce a change?
Thank you.
Comment 2 V Stuart Foote 2018-07-05 23:01:30 UTC
If as I suspect this is with OpenGL rendering enabled (default on Windows with GPU that support it) this is a dupe and has been fixed for the 6.0.6 build and 6.1.0 and master/6.2

If disabling OpenGL rendering and restarting does not clear things--reopen.

*** This bug has been marked as a duplicate of bug 116208 ***
Comment 3 mikemckibbin 2018-07-06 16:32:26 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi mikemckibbin,
> 
> I don't reproduce on Windows 7.
> There are two places where we find thoses stats: the first is Tools >
> statisticrs and the second is File > Propertics: Statistics tab. Counts are
> theys working there? If yes, can you restart LO with a new profile or use
> "Restart in safe mode..." in Help menu, which is equivalent to see if that
> produce a change?
> Thank you.

When I Restart in Safe Mode, Word Count does work fine. So it looks like it's something in the customizing or profile settings, something I changed?
Comment 4 mikemckibbin 2018-07-06 16:33:26 UTC
(In reply to V Stuart Foote from comment #2)
> If as I suspect this is with OpenGL rendering enabled (default on Windows
> with GPU that support it) this is a dupe and has been fixed for the 6.0.6
> build and 6.1.0 and master/6.2
> 
> If disabling OpenGL rendering and restarting does not clear things--reopen.
> 
> *** This bug has been marked as a duplicate of bug 116208 ***

Not sure what OpenGL is or how to change it...
Comment 5 mikemckibbin 2018-07-06 16:45:44 UTC
(In reply to mikemckibbin from comment #3)
> (In reply to Jacques Guilleron from comment #1)
> > Hi mikemckibbin,
> > 
> > I don't reproduce on Windows 7.
> > There are two places where we find thoses stats: the first is Tools >
> > statisticrs and the second is File > Propertics: Statistics tab. Counts are
> > theys working there? If yes, can you restart LO with a new profile or use
> > "Restart in safe mode..." in Help menu, which is equivalent to see if that
> > produce a change?
> > Thank you.
> 
> When I Restart in Safe Mode, Word Count does work fine. So it looks like
> it's something in the customizing or profile settings, something I changed?

Issue resolved. Once I unchecked (disabled) OpenGL option per comment below and restarted LO, Word Count works. Thanks.
Comment 6 mikemckibbin 2018-07-06 16:46:43 UTC
(In reply to mikemckibbin from comment #4)
> (In reply to V Stuart Foote from comment #2)
> > If as I suspect this is with OpenGL rendering enabled (default on Windows
> > with GPU that support it) this is a dupe and has been fixed for the 6.0.6
> > build and 6.1.0 and master/6.2
> > 
> > If disabling OpenGL rendering and restarting does not clear things--reopen.
> > 
> > *** This bug has been marked as a duplicate of bug 116208 ***
> 
> Not sure what OpenGL is or how to change it...

I looked up OpenGL and followed the easy instructions on Wikihow and issue was resolved. Thanks.
Comment 7 V Stuart Foote 2018-07-06 16:57:42 UTC

*** This bug has been marked as a duplicate of bug 116208 ***