Download it now!
Bug 118571 - LibO 6.1 Help does not work Windows builds
Summary: LibO 6.1 Help does not work Windows builds
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.0.2
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-07-06 10:43 UTC by kabilo
Modified: 2018-07-11 16:20 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
file structure inside help/es/text/swriter (89.12 KB, image/png)
2018-07-06 11:41 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kabilo 2018-07-06 10:43:08 UTC
Description:
Help does not work.

Verze: 6.1.0.1 (x64)
ID sestavení: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
Vlákna CPU: 4; OS: Windows 6.3; Vykreslování UI: výchozí; 
Národní prostředí: cs-CZ (cs_CZ); Calc: CL

Actual Results:
menu or button

Expected Results:
white area in browser


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-07-06 10:55:20 UTC
Confirmed in

Versión: 6.1.0.1
Id. de compilación: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

If I go to C:\Program Files\LibreOffice\help and open index.html I get

Firefox can't find the file in /C:/Program Files/LibreOffice/help/es-ES/text/shared/main0108.html?&DbPAR=WRITER&System=WIN.
Comment 2 Xisco Faulí 2018-07-06 10:57:54 UTC
The problem is it tries to find the file in

file:///C:/Program%20Files/LibreOffice/help/es-ES/text/shared/main0108.html?&DbPAR=WRITER&System=WIN

while it's in

file:///C:/Program%20Files/LibreOffice/help/es/text/shared/main0108.html?&DbPAR=WRITER&System=WIN

see the difference in es-ES and es....
Comment 3 Xisco Faulí 2018-07-06 11:40:57 UTC
For instance, if the numbering help in writer is open, it tries to open

file:///C:/Program%20Files/LibreOffice/help/index.html?swriter/cui/ui/numberingoptionspage/levellb?Language=es&System=WIN&Version=6.1

where swriter/cui/ui/numberingoptionspage/levellb doesn't exist
Comment 4 Xisco Faulí 2018-07-06 11:41:51 UTC
Created attachment 143346 [details]
file structure inside help/es/text/swriter
Comment 5 Xisco Faulí 2018-07-06 11:51:02 UTC
it looks fine on mac, where the URL looks like:

file:///Applications/LibreOffice%206.1%20RC1.app/Contents/Resources/help/en-US/text/shared/01/06050500.html?System=MAC&DbPAR=WRITER#bm_id3150040
Comment 6 kabilo 2018-07-06 13:26:34 UTC
I don't have problem with path (examples bellow), but it is always a white screen in the browser (Firefox).

help menu Calc
file:///C:/Program%20Files/LibreOffice/help/index.html?scalc/.uno:HelpIndex?Language=cs&System=WIN&Version=6.1
help button vlookup function
file:///C:/Program%20Files/LibreOffice/help/index.html?scalc/SC_HID_FUNC_SVERWEIS?Language=cs&System=WIN&Version=6.1
help button insert table in Writer
file:///C:/Program%20Files/LibreOffice/help/index.html?swriter/modules/swriter/ui/inserttable/help?Language=cs&System=WIN&Version=6.1
Comment 7 Olivier Hallot 2018-07-07 12:46:02 UTC
It is a packaging issue with Windows. No issue with Linux.

There is a spurious \help\ folder under libreoffice\help\ that contains files that must be in the upper level

In 
files in \libreoffice\help\help\ 

must be moved to 

\libreoffice\help

Raising importance. Packaging issue with msi
Comment 8 V Stuart Foote 2018-07-07 13:50:12 UTC
(In reply to Olivier Hallot from comment #7)
> In 
> files in \libreoffice\help\help\ 
> 
> must be moved to 
> 
> \libreoffice\help
> 

Thanks, checked with the rc1 (build 378e26bd4f22a135cef5fa17afd5d4171d8da21a), and the Help functions doing that as a work around. Allows testing 'til the help can be repackaged.
Comment 9 MBB 2018-07-07 17:14:13 UTC
Can confirm too (win7 x64)
LibreOffice_6.1.0.1_Win_x64.msi
LibreOffice_6.1.0.1_Win_x64_helppack_en-US.msi
When reverting back to old help (LibreOffice_6.0.5_Win_x64_helppack_en-US.msi ), it does work (shows help in LO popup window) 

Not sure where to find this " rc1 (build 378e26bd4f22a135cef5fa17afd5d4171d8da21a " to test it.
Comment 10 V Stuart Foote 2018-07-07 17:38:38 UTC
(In reply to MBB from comment #9)
> When reverting back to old help
> (LibreOffice_6.0.5_Win_x64_helppack_en-US.msi ), it does work (shows help in
> LO popup window) 

Why would one want to do that, mix 6.0.5 and 6.1.0 help content? Work around is to copy all contents of the help/help directory back one level.

> Not sure where to find this " rc1 (build
> 378e26bd4f22a135cef5fa17afd5d4171d8da21a " to test it.

rc1 is the 6.1.0.1 release build dated 2018-07-05, visible from Help -> About, i.e.

Version: 6.1.0.1 (x64)
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

when a new build is rolled, it will get a new time stamp. I'd keep an eye out for a new package in https://downloadarchive.documentfoundation.org/libreoffice/old
Comment 11 MBB 2018-07-08 06:42:52 UTC
(In reply to V Stuart Foote from comment #10)
> (In reply to MBB from comment #9)
> > When reverting back to old help
> > (LibreOffice_6.0.5_Win_x64_helppack_en-US.msi ), it does work (shows help in
> > LO popup window) 
> 
> Why would one want to do that, mix 6.0.5 and 6.1.0 help content? Work around
> is to copy all contents of the help/help directory back one level.

To test if the previous help worked, and to have a working help? 
The moving trick does give a working help in the browser (so thanks for that), but not inside a LO popup window. (Not a full fix)
I tend to update the help less often the program anyway, only at the major updates for the new features.

> > Not sure where to find this " rc1 (build
> > 378e26bd4f22a135cef5fa17afd5d4171d8da21a " to test it.
> 
> rc1 is the 6.1.0.1 release build dated 2018-07-05, visible from Help ->
> About, i.e.
> 
> Version: 6.1.0.1 (x64)
> Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
> CPU threads: 4; OS: Windows 10.0; UI render: GL; 
> Locale: en-US (en_US); Calc: CL
> 
> when a new build is rolled, it will get a new time stamp. I'd keep an eye
> out for a new package in
> https://downloadarchive.documentfoundation.org/libreoffice/old

I've looked there, but did not see a newer version (6.1.0.2 right?), and no "378e26bd4f22a135cef5fa17afd5d4171d8da21a" files or directories.
Comment 12 V Stuart Foote 2018-07-08 12:21:49 UTC
(In reply to MBB from comment #11)
> 
> To test if the previous help worked, and to have a working help? 
> The moving trick does give a working help in the browser (so thanks for
> that), but not inside a LO popup window. (Not a full fix)
> I tend to update the help less often the program anyway, only at the major
> updates for the new features.
> 

No, at 6.1 the "pop-up" help view (which used an HTML viewer internal to LibreOffice) has been replaced for the "new" help implementation. It will instead open into your system default HTML browser. And why testing it is worth doing the work around 'til it can be repackaged.

> I've looked there, but did not see a newer version (6.1.0.2 right?), and no
> "378e26bd4f22a135cef5fa17afd5d4171d8da21a" files or directories.

It may or may not get a 6.1.0.2 tag (hope it will not take that long), and likely will be just a swap out of the 6.1.0.1 files with new date stamps. The md5 hash (e.g. 378e2... ) is the build signature (taken from the git hash of the last commit pulled from source when finalizing the build) you'll find it in the installed (or unpacked) instance in the program/version.ini file.
Comment 13 Leopoldo Saggin 2018-07-08 14:21:40 UTC
I also can confirm this bug in LO 6.1.0 RC1
I use LibO with the American English interface and Italian settings (comma vs dot, main dictionary Italian etc..).
The Help I dowloaded was the American English one.
If I try to open Help -> LibreOffice Help (F1), a Firefox (my default browser) blank page opens while on the address bar this address is reported:
file:///C:/Program%20Files/LibreOffice/help/index.html?swriter/.uno:HelpIndex?Language=en-US&System=WIN&Version=6.1
Please note that this happens even after an installation from scratch of LibO was performed.
Everything was ok in the previous version I used, ie 6.0.5.2.

Regards,
Leopoldo Saggin aka Topoldo
Comment 14 Olivier Hallot 2018-07-09 15:20:00 UTC
(In reply to Olivier Hallot from comment #7)
> It is a packaging issue with Windows. No issue with Linux.
> 
> There is a spurious \help\ folder under libreoffice\help\ that contains
> files that must be in the upper level
> 
> In 
> files in \libreoffice\help\help\ 
> 
> must be moved to 
> 
> \libreoffice\help
> 
> Raising importance. Packaging issue with msi

Remark: The files to move are 
defaults.css
help.html
hid2file.js
etc... 
and are common to all languages.
Comment 15 Olivier Hallot 2018-07-10 00:32:18 UTC
ok so, help and core packaging are wrong

Help static files and media files should have gone into help package.

Instead they are wrapped in libobasis-core, which is not good because it makes the core package heavier for download and can potentially break the logic of detecting local help.

ref:

workdir/installation/LibreOfficeDev/deb/listfile/en-US/epm_gid_Module_Root.lst

that tell media file go to libreobasis-core
Comment 16 Olivier Hallot 2018-07-10 13:19:31 UTC
Please disregard comment #15.
Comment 17 Commit Notification 2018-07-10 16:37:35 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=89f1284e5b8017e7f13e7551559d5038e2c05399

tdf#118571 avoid MSI problems with double / in Package_html*.mk
Comment 18 Michael Stahl (CIB) 2018-07-11 10:14:07 UTC
the problem in comment #7 is fixed on master now

please check if there are still other problems
Comment 19 Commit Notification 2018-07-11 10:22:21 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=c6546852364c16f18a4e6a6409a4d2b6f26b10c7&h=libreoffice-6-1

tdf#118571 avoid MSI problems with double / in Package_html*.mk
Comment 20 Commit Notification 2018-07-11 11:39:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c6ca00e61c42bb7c43cbb7a3203d8bad5c0ed0e

related: tdf#118571 installer: error out if path contains "//"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.