Bug 118580 - PgUp/PgDn don't work in Impress in read-only mode
Summary: PgUp/PgDn don't work in Impress in read-only mode
Status: RESOLVED DUPLICATE of bug 101930
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-07-06 13:29 UTC by Federico Mena-Quintero
Modified: 2018-07-06 15:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Mena-Quintero 2018-07-06 13:29:56 UTC
Description:
Page Up and Page Down don't work in read-only mode.

Steps to Reproduce:
Open a presentation in read-only mode.  Hit PgUp/PgDn - they don't work to change between pages.

If you enable editing mode (or open a presentation in read/write mode), those keys work.


Actual Results:
The current slide remains displayed.

Expected Results:
The current slide should change when I hit PgUp/PgDn.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-07-06 15:33:37 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9149dbf17329180e2c9e2fb39243c65acc07a182

author	Yousuf Philips <philipz85@hotmail.com>	2015-11-20 09:40:59 +0400
committer	Yousuf Philips <philipz85@hotmail.com>	2015-12-07 15:44:08 +0000
commit	9149dbf17329180e2c9e2fb39243c65acc07a182 (patch)
tree	b2105cf48204bd9364352eb3f76c2cae51919f11
parent	bd7f0b0ba3391f3049cb3f2d7b70493a05362316 (diff)
tdf#91909 Add shortcuts to slide navigation

Bisected with: bibisect-linux-64-5.2

Adding Cc: to Yousuf Philips
Comment 2 Xisco Faulí 2018-07-06 15:34:59 UTC
Actually, there's already a report for it -> bug 101930.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 101930 ***