Download it now!
Bug 118584 - [NEWHELP] F1 key press while Add Tables dialog is open from the Query Designer window goes to the Help page on Query designer not the page specific to the Add Tables Dialog
Summary: [NEWHELP] F1 key press while Add Tables dialog is open from the Query Designe...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: New-Help
  Show dependency treegraph
 
Reported: 2018-07-06 15:09 UTC by Drew Jensen
Modified: 2018-08-07 16:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-07-06 15:09:07 UTC
Description:
Checked with Ubuntu 18.04 (64 bit) and build 
Version: 6.1.0.1
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

The F1 key and Help button on the Add Tables Dialog do no go to the same help page.

Steps to Reproduce:
1. Open an existing Base file with at least one table.
2. Go to the Query definition section.
3. Start the Query designer, (new query)
4. The Add Tables dialog box automatically opens on top of the Query designer window.
5. Click the help button on the Add Tables Dialog
6. The help page for the Add Tables Dialog opens. Close it
7. With the Add Tables Dialog still having focus enter the F1 key

Actual Results:
The general help page for Query Designer is displayed.

Expected Results:
The same help page as displayed by the HELP button on the dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2018-07-15 11:36:43 UTC
On master, F1 took me to Add Tables (local html file)

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 860a9daf2b45942a4b10ff22d36aa3fe29be19f4
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 14th 2018
Comment 2 Alex Thurgood 2018-07-31 08:12:30 UTC
Testing with

Version: 6.2.0.0.alpha0+
Build ID: 36e1f6ebf0c74b4b90bbf1aab8d9ab69b8746f3a
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group threaded

Pressing the Help button takes me to Add Tables help page.
Pressing the F1 key takes me to Add Tables help page.

@Drew, is that 6101 version a PPA, or a TDF release ?
Comment 3 Drew Jensen 2018-07-31 10:45:24 UTC
(In reply to Alex Thurgood from comment #2)
> Testing with
> 
> Version: 6.2.0.0.alpha0+
> Build ID: 36e1f6ebf0c74b4b90bbf1aab8d9ab69b8746f3a
> CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; 
> Locale: fr-FR (fr_FR.UTF-8); Calc: group threaded
> 
> Pressing the Help button takes me to Add Tables help page.
> Pressing the F1 key takes me to Add Tables help page.
> 
> @Drew, is that 6101 version a PPA, or a TDF release ?

There is a PPA version? 

With build f67c6912e8612c5850a5728c2222971b4ec130b9 (July 26th) it goes to the add tables section. 

With the Add tables dialog open in query designer (right as the beginning process of creating a query in this case) if I click on the help button the help page for Add Table is displayed:
.../libreofficedev6.1/help/en-US/text/shared/02/14020100.html?System=UNIX&DbPAR=BASE#bm_id3159224

However if I press the F1 key instead the help page displayed is different:
.../libreofficedev6.1/help/en-US/text/shared/explorer/database/02010100.html?System=UNIX&DbPAR=BASE#bm_id3152972
Comment 4 Xisco Faulí 2018-08-07 15:42:54 UTC
Hi  Drew Jensen,
Is this issue still reproducible in LibreOffice 6.1.0.3 ?
You can download it from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
Comment 5 Drew Jensen 2018-08-07 16:26:23 UTC
Tested with Ubuntu 18.04, Libo 6.1 RC3

Works as expected.

To be honest it seems I may of screwed up again. 

The difference between clicking the help button and hitting F1 is still there, but only when the focus changes away from the dialog box. If the focus isn't on the dialog box the F1 key take you to one page, but if you ensure the focus is in the dialog box the the F1 key takes you to the same help page as the 'Help' button on the dialog. That behavior would have to be case since that dialog allows you to work with the query designer window without closing the dialog first.

I can't say for sure that I simply didn't notice the change in focus before, and will set this to notabug.