Bug Hunting Session
Bug 118587 - [NEWHELP] Editing: Forms: Entering F1 key with embedded Form open for editing goes to Top level help page for Writer
Summary: [NEWHELP] Editing: Forms: Entering F1 key with embedded Form open for editing...
Status: RESOLVED DUPLICATE of bug 115254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-06 16:16 UTC by Drew Jensen
Modified: 2018-07-06 17:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drew Jensen 2018-07-06 16:16:01 UTC
Description:
Checked on Ubuntu 18.04 (64bit) build:
Version: 6.1.0.1
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded



Steps to Reproduce:
1. Open base file with at least one table.
2. Go to Forms section.
3. Select 'Create form in design view'
4. With blank form open enter F1

Actual Results:
The off-line help page for Writer is displayed:
file:///home/drew/Desktop/libreoffice6.1/help/en-US/text/swriter/main0000.html?System=UNIX&DbPAR=BASE#bm_id3147244

Expected Results:
Either the help page on Forms:
file:///home/drew/Desktop/libreoffice6.1/help/en-US/text/shared/guide/data_forms.html

or (and I think this is more accurate) the page on adding controls should display
file:///home/drew/Desktop/libreoffice6.1/help/en-US/text/shared/02/01170000.html?&DbPAR=WRITER&System=UNIX


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2018-07-06 17:35:07 UTC
I guess this is a dupe of bug 115254 as well...

*** This bug has been marked as a duplicate of bug 115254 ***