Bug Hunting Session
Bug 118630 - Automatic spell checker's context menu fails for automatically wrapped text
Summary: Automatic spell checker's context menu fails for automatically wrapped text
Status: RESOLVED DUPLICATE of bug 81894
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2018-07-09 08:05 UTC by OfficeUser
Modified: 2018-07-13 18:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
auto_wrap.ods (7.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-07-09 08:07 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2018-07-09 08:05:53 UTC
Description:
- Please open the attached Spreadsheet
- Make sure automatic spellchecking is enabled for German language

Note that cell A1 has cell attribute "Wrap text automatically" set. In cell A1 you find some red underlines text withy typos.

- Right-click on these words.

You will find that only for the first line (Hous Autu) correct spell checker context menu (with proposals for corrections) appears.
For the red underlined words in the second and third line only the (Cut, Copy, Paste...= contect menu appears.


Please note that forced line breaks (CTRL+RETURN) are not affected by the bug. It only happens with "Wrap text automatically".



Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
.
Comment 1 OfficeUser 2018-07-09 08:07:28 UTC
Created attachment 143392 [details]
auto_wrap.ods
Comment 2 Xisco Faulí 2018-07-11 08:31:21 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 3 OfficeUser 2018-07-12 14:21:31 UTC
Also reproducible with:

Version: 6.2.0.0.alpha0+
Build ID: 8e9d43546c8e46ea635472ddf07f5c183dc13360
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-12_01:06:03
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 4 Telesto 2018-07-12 14:36:06 UTC
Repro with
Version: 6.2.0.0.alpha0+
Build ID: 8e9d43546c8e46ea635472ddf07f5c183dc13360
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-12_01:16:00
Locale: nl-NL (nl_NL); Calc: CL

and with
Version: 4.3.0.4
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0

but not with
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 5 OfficeUser 2018-07-13 13:14:19 UTC
We had an already fixed bug where the spell checkers context menu did not show up at all, even not for the first line. Related? Bug 100880.
Comment 6 Telesto 2018-07-13 18:50:48 UTC

*** This bug has been marked as a duplicate of bug 81894 ***