Download it now!
Bug 118636 - SECTION: Wrong place of footnotes if sections has two or more columns (steps in comment 9)
Summary: SECTION: Wrong place of footnotes if sections has two or more columns (steps ...
Status: RESOLVED DUPLICATE of bug 54465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote Page-Layout-Columns
  Show dependency treegraph
 
Reported: 2018-07-09 14:31 UTC by Lafricain
Modified: 2018-07-17 14:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of what is expected (53.03 KB, image/png)
2018-07-09 14:33 UTC, Lafricain
Details
Doc with big blank places (27.52 KB, application/vnd.oasis.opendocument.text)
2018-07-09 14:34 UTC, Lafricain
Details
Doc without blank but with notes at the end of the section (27.57 KB, application/vnd.oasis.opendocument.text)
2018-07-09 14:35 UTC, Lafricain
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lafricain 2018-07-09 14:31:49 UTC
Description:
Currently if we use section with columns, and if we have notes, we have big blank space between the different sections. If we would not to have it we need to use the section option > notes > Move at the end of the text. But with this, the notes can be in the middle of the page!
What I'm waiting it is to stick the different section, with the notes always at the end of the page.

Steps to Reproduce:
1.Create a section with notes
2.
3.

Actual Results:
If notes big blank places can be.

Expected Results:
No blank places, the text following the section


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Lafricain 2018-07-09 14:33:31 UTC
Created attachment 143396 [details]
Example of what is expected
Comment 2 Lafricain 2018-07-09 14:34:11 UTC
Created attachment 143397 [details]
Doc with big blank places
Comment 3 Lafricain 2018-07-09 14:35:07 UTC
Created attachment 143398 [details]
Doc without blank but with notes at the end of the section
Comment 4 Buovjaga 2018-07-16 18:28:51 UTC
I don't understand the report. The documents you linked look identical, except example_col.odt has a one-column layout from page 5.
I am unable to determine what are the big blank places.
Comment 5 Dieter 2018-07-16 19:34:46 UTC
Lafricain, what I understand is, that you propose the possibilty to add footnotes not only at the end of a section or at the end of a text, but at the bottom of a page.

Is that right?
Comment 6 Buovjaga 2018-07-16 19:37:19 UTC Comment hidden (obsolete)
Comment 7 Dieter 2018-07-16 19:41:46 UTC
(In reply to Buovjaga from comment #6)
> Good point, then it would be bug 90921 which you are already familiar with :)

In my mind it is different from bug 90921. I just thought about footnotes like in a "normal" text and not within columns.
Comment 8 Lafricain 2018-07-17 08:11:06 UTC
> Lafricain, what I understand is, that you propose the possibilty to add
> footnotes not only at the end of a section or at the end of a text, but at
> the bottom of a page.
> 
> Is that right?

Yes, I will try to explain a little better. Currently, if you create a section in which there are notes, the next section or the text that follows is returned to a new page, and create big blank spaces.
If we choose the option to put the notes after the section, it is found between the two sections or section and the text that follows. What I would like is that the notes of the section be at the bottom of the page, but that the following section or the following text can be directly following the text section without being automatically moved to a new page and created large white space without text. As soon as I have a little time I will try to make a clearer model (unless you understand me :) ).
Comment 9 Dieter 2018-07-17 12:32:48 UTC
I confirm this with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL


Steps to reproduce
1. Open a new document
2. Write some text
3. Insert a section with two columns.
4. insert a footnotes within the section

Actual result:
section is extended until the end of the page and footnote is placed within the section.

Expected result:
Result like a section with one column: Height of the section doesn't change an footnote is placed at the end of the page.
Comment 10 Dieter 2018-07-17 12:36:14 UTC
I can also reproduce this with

Version: 4.4.7.2
Build-ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Gebietsschema: de_DE
Comment 11 Buovjaga 2018-07-17 14:12:11 UTC
Thanks, Dieter. I found an older report.

*** This bug has been marked as a duplicate of bug 54465 ***