Bug 118637 - EXPORT: XHTML: text missing after formula
Summary: EXPORT: XHTML: text missing after formula
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.5
Keywords: bibisected, regression
: 66645 108491 136606 (view as bug list)
Depends on:
Blocks: HTML-Export
  Show dependency treegraph
 
Reported: 2018-07-09 14:36 UTC by Xisco Faulí
Modified: 2021-07-14 08:08 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-07-09 14:36:48 UTC
This is a follow-up bug of bug 108491.

Steps to reproduce:
1. Open attachment 143362 [details] from bug 108491
2. Export it as XHTML
3. Check the output file

Observed behaviour: The text 'should be inline' after the formula is missing

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 67f3063b7c334d4d5c59132d90b938671aad09f0
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-07-09 14:38:07 UTC
According to attachment 143395 [details] this is not happening in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Adding regression keyword
Comment 2 Buovjaga 2018-07-09 15:41:59 UTC
Confirmed by Regina and me. I will bibisect this with win 5.4 repo.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 2cff0e2ceb53b2986be8788c7505cabbd04d0288
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 7th 2018
Comment 3 Buovjaga 2018-07-09 16:28:59 UTC
Hmh, sadly it gave me a range instead of a single commit: https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=169bd7718264b0e312052757f9bbd2321e1399c2...ff8b873936aa72b17309da4bfc2775573a5b1f55

Xisco can try on Linux later based on that range.
Comment 4 QA Administrators 2019-07-10 02:53:51 UTC Comment hidden (obsolete)
Comment 5 stragu 2021-05-19 07:22:57 UTC
This seems to be fixed in 7.2 branch.
Fix must have happened between 7.1 branch and 7.2 Alpha1+

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: b1c0734ffe0f395757b6e0cea7830d820231afeb
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-05-18_03:16:20
Calc: threaded
Comment 6 Xisco Faulí 2021-05-19 08:24:11 UTC
This issue got fixed by

author	Svante Schubert <svante.schubert@gmail.com>	2020-09-09 15:27:54 +0200
committer	Michael Stahl <michael.stahl@allotropia.de>	2021-03-02 13:24:15 +0100
commit f680b6d74209fd78c547201b2f14c6547e55c81b (patch)
tree 1392dbf48686a0a50ac8c0aef4ddf5b76965d72b
parent 86ca384cab26f2731e099c821edfa9636f8b55d5 (diff)
HTML XSLT: Adding missing MathML siblings. The floating draw:frame sibling content being text were not shown, nor further occuring draw:frame (other MathML)

and

author	Svante Schubert <svante.schubert@gmail.com>	2020-09-10 16:17:37 +0200
committer	Michael Stahl <michael.stahl@allotropia.de>	2021-03-02 13:24:37 +0100
commit 06eb655e2c83df8eeeb0c0828f8ac34f13e386af (patch)
tree 92df2949329ef6a1c3a3b68795f81946041d1bc5
parent f680b6d74209fd78c547201b2f14c6547e55c81b (diff)
HTML MathML update - enabling inline MATHML & fixing duplication (regression from last commit)
Comment 7 Commit Notification 2021-05-19 09:38:47 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0655560f1b8aff45954682bb92498570f2000014

tdf#118637: sw_xhtmlexport: Add unittest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2021-05-19 14:04:57 UTC
*** Bug 136606 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2021-05-21 07:33:57 UTC
Svante Schubert committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/932be9b55ce8b996184e724127925c436130cecd

tdf#118637: HTML XSLT: Adding missing MathML siblings.

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-05-21 08:18:55 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/969379e9704fe124eec8ec0d7b945cfcf39b1c81

tdf#118637: sw_xhtmlexport: Add unittest

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 BogdanB 2021-05-25 17:14:46 UTC
The text is inline in Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: 42d2b2d55a27f11153ea1713737d93540a19211d
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 12 Xisco Faulí 2021-06-29 13:04:10 UTC
*** Bug 108491 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2021-07-14 08:08:42 UTC
*** Bug 66645 has been marked as a duplicate of this bug. ***