Bug Hunting Session
Bug 118733 - Insert → Object → Formula should be renamed to avoid clash with Table → Formula
Summary: Insert → Object → Formula should be renamed to avoid clash with Table → Formula
Status: RESOLVED DUPLICATE of bug 108458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2018-07-12 19:32 UTC by RGB
Modified: 2018-07-13 13:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
"Formula" name clash (58.17 KB, image/png)
2018-07-12 19:32 UTC, RGB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2018-07-12 19:32:45 UTC
Created attachment 143524 [details]
"Formula" name clash

"Insert → Object → Formula" and "Table → Formula" do different things, but both are called "formula," which is wrong. This can lead to some confusion when adding a keyboard shortcut to insert a Math object, as can be seen on the attached screenshot.
Comment 1 V Stuart Foote 2018-07-13 02:23:50 UTC
Can't say that I have ever had much difficulty keeping an ODF Math Formula separate from a Calc or Table Formula.

IMHO => WF
Comment 2 Regina Henschel 2018-07-13 12:38:05 UTC
The problem is not only with "Formula" but with other duplicate items too. The problem is discussed in bug 108458. There other duplicates are listed too.

I set this to "duplicate". If someone is going to fix only this "Formula" case, he can reopen the issue.

(In reply to V Stuart Foote from comment #1)
> Can't say that I have ever had much difficulty keeping an ODF Math Formula
> separate from a Calc or Table Formula.

Please look at the attached screenshot. It is indeed a problem, because the dialog tab for customizing of shortcuts have no icons by which you would be able to distinguish the items. That is different from customizing toolbars.

And even in the tab for toolbars you get problems, if there is no icon or the icons are identical.

And in case you have no help installed, you cannot even get the difference by reading the description.

*** This bug has been marked as a duplicate of bug 108458 ***
Comment 3 V Stuart Foote 2018-07-13 13:36:43 UTC
(In reply to Regina Henschel from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 108458 ***

Knew I'd seen this issue before but forgot the context. The dup is correct.

/me embarrassed, since it was my issue... and there were also bug 116909 and bug 116494