Download it now!
Bug 118761 - Opening Autocorrect options the first time takes 10 seconds (Linux-only)
Summary: Opening Autocorrect options the first time takes 10 seconds (Linux-only)
Status: RESOLVED DUPLICATE of bug 109158
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, perf, regression
Depends on:
Blocks:
 
Reported: 2018-07-14 15:51 UTC by Buovjaga
Modified: 2018-07-15 10:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Callgrind output from master (2.40 MB, application/x-xz)
2018-07-14 19:38 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2018-07-14 15:51:59 UTC
1. On Linux, with any VCL backend, any application - Tools - AutoCorrect Options

The first time takes 10 seconds, the next times are fast.

Arch Linux 64-bit
Version: 6.0.5.2
Build ID: 6.0.5-1
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 860a9daf2b45942a4b10ff22d36aa3fe29be19f4
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 14th 2018
Comment 1 V Stuart Foote 2018-07-14 16:59:04 UTC
No issue on Windows builds

Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 10.0; UI render: GL or default; 
Locale: en-US (en_US); Calc: CL

~2 seconds

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 4b7ce45c2384fdd65c17ab18036899cd76577254
CPU threads: 4; OS: Windows 10.0; UI render: GL or default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-07-14_01:26:50
Locale: en-US (en_US); Calc: CL

~3 seconds
Comment 2 Buovjaga 2018-07-14 17:06:23 UTC
Yep, I should have been more explicit about the Linux-onlyness, tweaking summary.
Comment 3 Drew Jensen 2018-07-14 18:09:43 UTC
(In reply to Buovjaga from comment #2)
> Yep, I should have been more explicit about the Linux-onlyness, tweaking
> summary.

The difference between first open and subsequent is also there using Ubuntu 18.04 (64bit) with LibO 5.4.7.2, and confirmed it is also there in LibO 6.2Alpha.

Also, with 5.4.7.2 the difference is less than with 6.2Alpha. 

On my machine first open time:
5.4.7.2  -> 6 seconds
6.2Alpha -> 9 seconds

Subsequent opens are less than 1 second for both.
Comment 4 Buovjaga 2018-07-14 19:38:13 UTC
Created attachment 143548 [details]
Callgrind output from master

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 860a9daf2b45942a4b10ff22d36aa3fe29be19f4
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 14th 2018

On Ubuntu 14.04, last commit of 50max repo, the dialog opens instantly.
Comment 5 Xisco Faulí 2018-07-15 10:41:36 UTC
The bisection points to 94c7a401583200cf5982594b1b043ad1a5e3cd38, which is the same as in bug 109158

*** This bug has been marked as a duplicate of bug 109158 ***