Bug 118778 - LO 6.1.RC1: Truncated text of categories in calc charts
Summary: LO 6.1.RC1: Truncated text of categories in calc charts
Status: RESOLVED DUPLICATE of bug 117088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 117992 (view as bug list)
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2018-07-16 09:00 UTC by Jörn Schwarz
Modified: 2019-12-11 15:49 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Small calc file with data and chart with truncated text of categories (18.89 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-07-16 09:05 UTC, Jörn Schwarz
Details
Screenshot of the example file in LO 5.3 and 6.3 master (205.03 KB, image/png)
2019-05-22 08:30 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jörn Schwarz 2018-07-16 09:00:58 UTC
Description:
The text of categories in calc charts, 
which were generated with calc 5.4.x.x and before, 
are truncated if opened under calc 6.1.RC1.

Steps to Reproduce:
1.Create a bar chart with calc 5.4.xx with some named categories and save it.
2.Open the calc file with LO 6.1.
3.The text of the categories will be truncated.
4. This also happens sometimes with x- and y-axis in X-Y (Scatter) charts.

Actual Results:
Open some old calc files which contain charts.


Expected Results:
You'll see a lot of truncated text (categories, axis)


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
the chart should look like it was created with to old LO version
Comment 1 Jörn Schwarz 2018-07-16 09:05:18 UTC
Created attachment 143568 [details]
Small calc file with data and chart with truncated text of categories
Comment 2 raal 2018-07-16 20:59:23 UTC
This seems to have begun at the below commit.
Adding Cc: to Szymon Kłos ; Could you possibly take a look at this one?
Thanks

494071baf8e78dec83335bf8338baebcba6a774a is the first bad commit
commit 494071baf8e78dec83335bf8338baebcba6a774a
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Sun Mar 4 12:27:31 2018 +0100

    source sha:35d062f7879d5414334643cb90bff411726b2168
author	Szymon Kłos <szymon.klos@collabora.com>	2018-03-02 10:39:33 +0100
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-03-04 12:11:09 +0100
commit	35d062f7879d5414334643cb90bff411726b2168 (patch)
tree	9d04dcd4ec3c504b1d6a3e250883e0ce4033d518
parent	0a3151314ad78b86bbb4bd76bac678fbaa9caf06 (diff)
tdf#116163: Limit label height in chart if needed
Comment 3 Szymon Kłos 2018-07-17 09:33:52 UTC
I see, horizontal labels case was not handled in my code. I will try to fix soon.
Comment 4 Buovjaga 2019-05-19 13:48:45 UTC
*** Bug 117992 has been marked as a duplicate of this bug. ***
Comment 5 Gabor Kelemen 2019-05-22 08:30:35 UTC
Created attachment 151587 [details]
Screenshot of the example file in LO 5.3 and 6.3 master

Still happens.
Comment 6 Xisco Faulí 2019-12-11 15:49:07 UTC
it seems to be a duplicate of bug 117088

*** This bug has been marked as a duplicate of bug 117088 ***