Bug 118794 - [DOCX] tables are slipping into one another
Summary: [DOCX] tables are slipping into one another
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
: 78755 115188 (view as bug list)
Depends on:
Blocks: DOCX-Floatingtable
  Show dependency treegraph
 
Reported: 2018-07-17 07:18 UTC by Pénzes Dávid
Modified: 2021-01-21 10:31 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file. (19.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-07-17 07:19 UTC, Pénzes Dávid
Details
The tables in Word (good result). (124.06 KB, image/png)
2018-07-17 07:21 UTC, Pénzes Dávid
Details
The tables in Writer (bad result). (136.98 KB, image/png)
2018-07-17 07:22 UTC, Pénzes Dávid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pénzes Dávid 2018-07-17 07:18:57 UTC
Description:
The first and the second table is slipping into one another.

Steps to Reproduce:
1. Opening the attachment in Microsoft Word.
2. Opening the attachment in LibreOffice Writer.


Actual Results:
x

Expected Results:
The first and the second table is not slipping into one another.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Pénzes Dávid 2018-07-17 07:19:57 UTC
Created attachment 143586 [details]
The original file.
Comment 2 Pénzes Dávid 2018-07-17 07:21:06 UTC
Created attachment 143587 [details]
The tables in Word (good result).
Comment 3 Pénzes Dávid 2018-07-17 07:22:37 UTC
Created attachment 143588 [details]
The tables in Writer (bad result).
Comment 4 László Németh 2018-07-17 09:42:42 UTC
It seems, one of the tables is there in a frame unnecessarily. (Unfortunately, it's very easy to do that unintentionally in MS Word with the table handles.)
Comment 5 Xisco Faulí 2018-07-18 18:15:18 UTC
Reproduced back to

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 7 Justin L 2018-08-11 13:26:40 UTC
Almost certainly caused by making the table floating from
Miklos Vajna 2012-08-21 17:48:13 +0200
commit	edc4861a68e0269b83b17e0ec57912a1ce4220ad
n#775899 initial docx import of w:vertAnchor inside w:tblpPr

CC: Miklos

But the wrapping code obviously isn't working in this case, so more like it exposed another problem than caused a regression.  The first table IS supposed to be a floating table as mentioned in comment 4.
Comment 8 QA Administrators 2019-08-19 06:55:07 UTC Comment hidden (obsolete, spam)
Comment 9 Justin L 2020-02-27 04:40:48 UTC
Fixed for LO 7.0 by commit fd7749fddc5a767461dfced55369af48e5a6d561
Author: Miklos Vajna   Fri Feb 14 16:29:44 2020 +0100
    sw: fix handling of table vs fly overlaps in the AddVerticalFlyOffsets case
Comment 10 Miklos Vajna 2020-02-27 08:08:47 UTC
Thanks for updating this bug! I'm not great at searching for duplicates in bugzilla.
Comment 11 Xisco Faulí 2020-02-27 08:15:36 UTC
Indeed. Verified in

Version: 7.0.0.0.alpha0+
Build ID: c8d764b3f27c2bb0712745891b70630e94436317
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 12 Justin L 2021-01-21 10:07:00 UTC
*** Bug 78755 has been marked as a duplicate of this bug. ***
Comment 13 Aron Budea 2021-01-21 10:22:57 UTC
*** Bug 115188 has been marked as a duplicate of this bug. ***