Bug Hunting Session
Bug 118856 - Text flickering when highlighting text in about us windows
Summary: Text flickering when highlighting text in about us windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.2 target:6.3.1
Keywords: preBibisect, regression
Depends on:
Blocks: RenderContext Flickering-UI
  Show dependency treegraph
 
Reported: 2018-07-20 13:01 UTC by revsamtp
Modified: 2019-08-19 11:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description revsamtp 2018-07-20 13:01:25 UTC
Description:
This is a small problem and it must have been reported already, I don't really know.
When opening the about page and highlighting the text in the about us window, it starts blinking and it stops after you have finished highlighting the text. I noticed this problem while using writer

Steps to Reproduce:
1.Open Libreoffice Writer
2.Press help and then press about us
3.Highlight the text where it says the version and os info

Actual Results:
The text starts blinking when it gets highlighted

Expected Results:
The text is not supposed to blink and supports to stay still.


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-in
Module: TextDocument
[Information guessed from browser]
OS: Windows 10
OS is 64bit:yes
Version: 6.1.0.1 (x64)
Build ID: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-IN (en_IN); Calc: CL
Comment 1 Dieter Praas 2018-07-20 14:01:30 UTC
Can't confirm this with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: b0e291a7efcd3af2a72d0b622b1f1b84723f011f
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-30_23:43:40
Locale: en-US (de_DE); Calc: CL
Comment 2 Jean-Baptiste Faure 2018-07-20 15:59:44 UTC
Not reproducible for me with LO 6.1.1.0.0+ built at home under Ubuntu 16.04 x86-64. I do that often with development versions for QA purpose and I never saw the described behavior.

Best regards. JBF
Comment 3 raal 2018-07-20 16:35:16 UTC
I can confirm with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 2c85607101e2e04e870e3b87362f39f9a9148e6c
CPU threads: 1; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-06-16_00:12:37

It doesn't blink everytime and most visible it's on the last line. Blink the non selected text.
Comment 4 raal 2018-07-20 16:36:44 UTC
It's correct in version  6.0.4.2
Comment 5 V Stuart Foote 2018-07-21 15:49:23 UTC

*** This bug has been marked as a duplicate of bug 113714 ***
Comment 6 V Stuart Foote 2018-07-21 15:59:58 UTC
Need to be clear that "blinking" and "flickering" are different effects--a blink would be based on a timer of some sort, while flicker is a response to some user control change to the UI.

As here mouse/cursor movement through the text of the Help -> About dialog. Or as in bug 113714 advancing through the main menu bar items.

Any other flicker or blinking would not be under control of LibreOffice, e.g. Desktop Environment and GPU driver mismatch.
Comment 7 Aron Budea 2019-05-27 00:00:54 UTC
Reproduced in 4.0.0.3, good in 3.6.0.4.
Comment 8 Commit Notification 2019-08-12 12:37:33 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7eb37a422f2e66bc177d72404c53659a248661ca%5E%21

tdf#118856 vcl: avoid flicker in the about dialog

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-08-16 16:13:06 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/0df3e9fd645e9613c4a852b4a0966ff2eea7e313%5E%21

tdf#118856 vcl: avoid flicker in the about dialog

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-08-19 11:08:58 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-1":

https://git.libreoffice.org/core/+/813474dbe134e3dda538d0f534032a71f8f3b9c0%5E%21

tdf#118856 vcl: avoid flicker in the about dialog

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.