Bug 118893 - CRASH Impress: UI locks up when I drag a slide from the left "Slides" view to the Windows taskbar
Summary: CRASH Impress: UI locks up when I drag a slide from the left "Slides" view to...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: All Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.0.0 target:6.4.3 target:6.3....
Keywords: bibisected, regression
: 131050 (view as bug list)
Depends on:
Blocks: CPU-AT-100%
  Show dependency treegraph
 
Reported: 2018-07-22 20:09 UTC by Colin Finck
Modified: 2020-03-11 12:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
stack trace of hang on dragging slide to drop on Impress jump list (34.57 KB, text/plain)
2018-07-26 02:56 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Finck 2018-07-22 20:09:51 UTC
Description:
1. Open LibreOffice Impress with a new empty presentation.
2. Move the mouse to the left "Slides" view over the only slide that is shown there and hold down the left mouse button to drag the slide.
3. Without releasing the mouse button, drag the slide downwards until the mouse leaves the LibreOffice UI and is over the Windows taskbar.

You can now release the left mouse button and try to return to the LibreOffice window. However, the mouse cursor is now eternally in the "Slashed circle" shape and the LibreOffice UI is locked up until it is killed in Task Manager.

Tested on Windows 10 x64 with LibreOffice 6.0.5.2 (x64).

Steps to Reproduce:
See Description

Actual Results:
Lock-up

Expected Results:
Being able to continue as usual and not lose unsaved work.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2018-07-26 02:54:16 UTC
Confirmed on Windows 10 Home 64-bit en-US with
Version: 6.1.0.2 (x64)
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

stack trace attached
Comment 2 V Stuart Foote 2018-07-26 02:56:02 UTC
Created attachment 143765 [details]
stack trace of hang on dragging slide to drop on Impress jump list
Comment 3 Xisco Faulí 2018-07-27 09:08:44 UTC
Only win, I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 96faaa6005465661d74b6dbf4879c43b85c68a55
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 5 Xisco Faulí 2018-07-27 10:12:50 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/sd?id=aa0d0536a444fb26d9e570bd6bf6c1bdc3596cf3 looks like a good candidate...
it would be nice if someone can revert it locally...
Comment 6 QA Administrators 2019-08-03 03:05:50 UTC Comment hidden (obsolete)
Comment 7 Oliver Grimm 2020-03-01 20:48:58 UTC
*** Bug 131050 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2020-03-01 21:05:01 UTC
confirm this remains an issue on

Version: 6.4.1.2 (x64)
Build ID: 4d224e95b98b138af42a64d84056446d09082932
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Either drag-n-drop onto taskbar, or directly on Impress jump list launcher.
Comment 9 fred4u 2020-03-02 07:38:26 UTC
Added the word CRASH to Subject (https://wiki.documentfoundation.org/QA/BugReport)
Possible user data loss.
Comment 10 Mike Kaganski 2020-03-02 09:39:25 UTC
https://gerrit.libreoffice.org/c/core/+/89815
Comment 11 Commit Notification 2020-03-02 12:07:21 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/788ffc0360e44c54947bdead6d1eb368e5283915

tdf#118893: avoid nullptr dereference

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2020-03-02 18:15:24 UTC
Verified in

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 59b755eb93136ea28916e875ee28a50ac7c12fb5
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Mike, thanks for fixing this issue!
Comment 13 Commit Notification 2020-03-03 07:53:15 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/8ebb41ba032ac341f1b0e8fcfe79581488ef75bd

tdf#118893: avoid nullptr dereference

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-03-03 07:53:30 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/7282aecb75c813317e2038c3bae961698ef9f75d

tdf#118893: avoid nullptr dereference

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-03-11 12:58:17 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-2":

https://git.libreoffice.org/core/commit/afc8459918f92a3b55ed5de3daceb5c0cd2a5cb8

tdf#118893: avoid nullptr dereference

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.