Bug 118910 - In an left-to-right comment, inserting bolded right-to-left text (e.g., Hebrew) messes up the spacing
Summary: In an left-to-right comment, inserting bolded right-to-left text (e.g., Hebre...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-CTL Writer-Comments
  Show dependency treegraph
 
Reported: 2018-07-24 07:13 UTC by William Friedman
Modified: 2018-10-03 16:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Here is a SWF demonstrating the problem. (1.23 MB, application/x-shockwave-flash)
2018-07-24 07:19 UTC, William Friedman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Friedman 2018-07-24 07:13:24 UTC
Description:
When I create a comment with left-to-right text and try to insert text in a right-to-left language like Hebrew, bolding part of the RTL causes the spacing to get messed up.

Steps to Reproduce:
1. Insert a comment in a text document.
2. Type some text in English. 
3. Switch to Hebrew, keeping the text in left-to-right mode.
4. Type three words in Hebrew.
5. Bold the middle word.

Actual Results:
The space between the middle word and the first word gets eliminated and inserting more spaces does not fix the problem.

Expected Results:
The text should have been bolded without messing up the spacing.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 William Friedman 2018-07-24 07:19:05 UTC
Created attachment 143724 [details]
Here is a SWF demonstrating the problem.
Comment 2 William Friedman 2018-07-24 07:19:57 UTC
As you can see from the attached video, the problem sometimes happens and sometimes does not.
Comment 3 Xisco Faulí 2018-08-29 10:47:26 UTC
@Lior, I thought you could be interested in this issue...
Comment 4 Idan Miara 2018-09-17 19:45:35 UTC
Following the SWF video I couldn't reproduce this bug on the 6.1.1.2 on Win10.
Was it fixed?
Comment 5 Lior Kaplan 2018-09-30 19:27:22 UTC
@William - Could you upload a test document?

I can't reproduce this either with version 6.1.1.2 on Linux.
Comment 6 William Friedman 2018-10-03 16:01:05 UTC
Seems to be working on 6.0.5.2 on Win7 as well. Thanks!
Comment 7 Dieter Praas 2018-10-03 16:14:04 UTC
(In reply to William Friedman from comment #6)
> Seems to be working on 6.0.5.2 on Win7 as well. Thanks!

=> William I e can close this as WORKSFORME. Feel free to reopen it, if it appears again.