Download it now!
Bug 118954 - XML Form Document: Impossible to save a data type in a second instance in the same model
Summary: XML Form Document: Impossible to save a data type in a second instance in the...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-26 13:22 UTC by Robert Großkopf
Modified: 2019-07-30 07:51 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Try to save data type in elements of the instance "Personen" (10.10 KB, application/vnd.oasis.opendocument.text)
2018-07-26 13:22 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-07-26 13:22:55 UTC
Created attachment 143785 [details]
Try to save data type in elements of the instance "Personen"

Open the attached xmlform.odt 
There is created a second instance "Personen" (only creatable with daily build from 2018-07-26 or newer, see bug118862)
Go to instanceData > Vorname
Edit the element and set data type to "String".
Press "OK".
Reopen the element and have a look.
No data type has been saved.

This is a serious problem for XML-Forms. There were created bindings for this element (don't know why, but there are created two bindings for every element in the second instance - deleting one of them creates two new ...). The bindings contain the data type.
I have created bindings without data type - but it won't work. XML-Forms will need a datatype for every content, which should be saved in the form. So the fields of the form will appear with a red border to say: Wrong data type - couldn't be saved.

Tested with
Version: 6.2.0.0.alpha0+
Build ID: f30afe009e9e9da32dfc0aa1490d1f7ce787d101
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-26_01:22:00
Locale: de-DE (de_DE.UTF-8); Calc: group threaded

On OpenSUSE 42.3 64bit rpm Linux
Comment 1 Robert Großkopf 2018-07-27 18:17:10 UTC
It's the same buggy behavior in LO 3.6.7.2 - so could be inherited by OOo.

Could be it is better to block to create a second instance (see bug 118862), because there will be a second bug if this bug has been solved: 
Every time I open the xform-document new bindings for the second instance will be created automatically ...
Comment 2 Thomas Hackert 2018-07-29 16:29:31 UTC
Hello Robert, *,
thank you very much for reporting this bug :)

I can reproduce it with

OS: Debian Testing AMD64
LO: Version: 6.2.0.0.alpha0+
Build-ID: 5a7d18e432571fb1e9b2cd54d6168353d25c6f19
CPU-Threads: 4; BS: Linux 4.17; UI-Render: Standard; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-26_22:07:10
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group threaded

HTH and have a nice evening
Thomas.
Comment 3 QA Administrators 2019-07-30 03:13:45 UTC Comment hidden (obsolete)
Comment 4 Robert Großkopf 2019-07-30 07:27:02 UTC
Bug still exists in LO 6.3.0.2 on OpenSUSE 15 64bit rpm Linux. 

Note: Form-controls aren't visible with GTK3: Bug 122358
Data Navigator isn't shown any more in the standard toolbar. So you have to change the content of a toolbar ad have to add the Data Navigator to look for this bug.
Comment 5 Robert Großkopf 2019-07-30 07:51:17 UTC
New bug - you couldn't see the data navigator any more: bug 126611