Bug 118967 - HANG: Pasting text in a table and undoing it
Summary: HANG: Pasting text in a table and undoing it
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Paul Trojahn
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, regression
: 119341 121773 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-27 10:26 UTC by Xisco Faulí
Modified: 2018-11-28 22:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-07-27 10:26:32 UTC
This is a follow-up bug of bug 115438 based on https://bugs.documentfoundation.org/show_bug.cgi?id=115438#c9 as it's still reproducible on master

STR:
1. Open Impress
2. Insert a table
3. Add some text to A1
4. Select the text with Ctrl + A and copy it
5. Paste the text in A2 3 times
6. Undo 4 times

-> LibreOffice hangs

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: aa84f1458f422c1acf38b53a3e3138cd0e84e313
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-07-27 10:28:00 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5131f5ba19ebc5de17139dbcf373866a9b155b2b

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-08-10 20:08:56 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-08-11 08:51:43 +0200
commit	5131f5ba19ebc5de17139dbcf373866a9b155b2b (patch)
tree	627beb6b4b636e0161ba92ecf7fc3005a2c3b983
parent	46b4eb8b0e9325f8c29cd391baf9504bccee1837 (diff)
editviewoverlay: corrected AttributeChange
EditView on Overlay visualization needs to handle
selection change when e.g. FontSize attribute of
a selected text portion changes. Changed handling
so that selection overlay is an integral part of
text visualization overlay and refreshing text
visualization always refreshes selection visuals,
but not the other way around. Both anyways check
for real change, so just extra testing is avoided
which is still the better solution

Bisected with: bibisect-linux64-6.0

Adding Cc: to Armin Le Grand
Comment 2 Commit Notification 2018-09-04 07:42:12 UTC
Paul Trojahn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6b669c9d9ee61c5c37c384c3a546467a048f5636

tdf#118967 Batch all a11y notifications

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2018-09-11 08:38:01 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 2da435922f9c1fcf52eb0c1eb3d6f73581e9f793
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Paul Trojahn, Thanks for fixing this!!
Comment 4 Xisco Faulí 2018-09-22 18:30:25 UTC
*** Bug 119341 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2018-09-22 18:31:50 UTC
Hi Paul,
You commit fixes this issue and bug 119341 and probably some other slownesses.
Should it be backported to 6.1 branch ?
Comment 6 Paul Trojahn 2018-09-23 21:58:42 UTC
Not sure. It works on 6.1 on my machine, but it seems like a pretty large patch to backport. What do you think?
Comment 7 Xisco Faulí 2018-11-28 22:29:48 UTC
*** Bug 121773 has been marked as a duplicate of this bug. ***