Bug Hunting Session
Bug 118993 - Calc/Draw/Impress/Web: Old Insert Special Symbol
Summary: Calc/Draw/Impress/Web: Old Insert Special Symbol
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.2 rc
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
: 116355 (view as bug list)
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2018-07-30 07:49 UTC by Rizal Muttaqin
Modified: 2018-09-17 05:08 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
the new button is there (89.25 KB, image/png)
2018-09-16 14:52 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-07-30 07:49:37 UTC
Description:
Open LibreOffice Calc and in standard Toolbar there's no new Special Symbol function. Calc still use the old one instead

Steps to Reproduce:
1.Open Calc
2.Make sure standard toolbar opened
3.

Actual Results:
Old Insert Special Character function being used

Expected Results:
New Insert Special Character function (with drop-down menu) being used


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: 1b21ff86effe58ae368457de8fec654ba4c8edd9
CPU threads: 2; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-30_01:42:51
Locale: id-ID (id_ID.UTF-8); Calc: group threaded
Comment 1 Xavier Van Wijmeersch 2018-07-30 08:26:58 UTC
confirm with

Version: 6.2.0.0.alpha0+
Build ID: c21612e5e18d632fd2073e4f3c717613051133ed
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 2 Xisco Faulí 2018-07-30 08:43:51 UTC
Confirmed in

Version: 6.2.0.0.alpha0+
Build ID: 72b099d279e7096d41a04fe8c0dd493a5fc18a33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

and

Versión: 6.1.0.2
Id. de compilación: b3972dcf1284967612d5ee04fea9d15bcf0cc106
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded
Comment 3 Heiko Tietze 2018-07-30 10:26:18 UTC
Draw/Impress likely as well.
Comment 4 Rizal Muttaqin 2018-08-04 13:15:45 UTC
LibreOffice Writer/Web also (Reproducible by creating a new HTML document)

Version: 6.2.0.0.alpha0+
Build ID: 7e65a0794b7c57210779bb9a6d1f2b2e49eb86e9
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-07-31_01:40:24
Locale: id-ID (id_ID.UTF-8); Calc: group threaded

and

Version: 6.1.0.1.0+
Build ID: 36f411db7aa6682fd30d0bb9b181c144d5c24cfd
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-07-06_08:46:27
Locale: id-ID (id_ID.UTF-8); Calc: group threaded
Comment 5 Heiko Tietze 2018-08-04 13:56:40 UTC
Waiting for review at https://gerrit.libreoffice.org/#/c/58323/
Comment 6 Commit Notification 2018-08-23 23:53:10 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84c1b71f2bc525597e0877a2abd235a69dbc00d6

tdf#118993 - Missing new Insert Special Character in Calc

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Heiko Tietze 2018-08-24 07:45:46 UTC
*** Bug 116355 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-08-30 22:37:07 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7fc4aa739c6913c14bea7485919818f6da5f8c38

tdf#118993 - Missing new Insert Special Character in Web

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Heiko Tietze 2018-08-31 07:58:17 UTC
(In reply to Commit Notification from comment #8)
> Rizal Muttaqin committed a patch related to this issue.

Oups, forgot this module. Thanks for the amendment.
Comment 10 Rizal Muttaqin 2018-08-31 08:20:34 UTC
Should we add it again to Math?
Comment 11 Heiko Tietze 2018-08-31 08:21:09 UTC
(In reply to Rizal Muttaqin from comment #10)
> Should we add it again to Math?

Yes, please.
Comment 12 Rizal Muttaqin 2018-08-31 08:26:10 UTC
I've found Writer in master document mode (File > New > Master Document) also missed new Insert Special Symbol.
Comment 13 Commit Notification 2018-09-02 18:41:04 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a9f682de7727e5873323b68405a4aecd785057e

tdf#118993 - Missing new Insert Special Character in Writer (global)

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 BogdanB 2018-09-16 14:52:49 UTC
Created attachment 144910 [details]
the new button is there

The new mbutton for ionserting sybols is there. Please see the screenshot.

Confirm on:
Version: 6.2.0.0.alpha0+
Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-15_02:08:38
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 15 Rizal Muttaqin 2018-09-17 02:21:00 UTC
(In reply to BogdanB from comment #14)
> Created attachment 144910 [details]
> the new button is there
> 
> The new mbutton for ionserting sybols is there. Please see the screenshot.
> 
> Confirm on:
> Version: 6.2.0.0.alpha0+
> Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
> CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
> TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time:
> 2018-09-15_02:08:38
> Locale: ro-RO (ro_RO.UTF-8); Calc: threaded

There's already patch for this bug and the status is RESOLVED FIXED. Thanks for your report.