Bug 119000 - FILESAVE: PPTX: drawings change position after RT
Summary: FILESAVE: PPTX: drawings change position after RT
Status: RESOLVED DUPLICATE of bug 91999
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-07-30 12:00 UTC by Xisco Faulí
Modified: 2018-07-31 19:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.2 (1.18 MB, image/png)
2018-07-30 12:00 UTC, Xisco Faulí
Details
triangles changes position after RT (23.50 KB, application/vnd.ms-powerpoint)
2018-07-30 13:53 UTC, Xisco Faulí
Details
bottom arrow changes position after RT (29.77 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-07-30 13:57 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-07-30 12:00:42 UTC
Created attachment 143825 [details]
comparison MSO 2010 and LibreOffice 6.2

Steps to reproduce:
1. Open attachment 60723 [details] from bug 49247
2. save it as .PPTX
3. Open the new file

Observed behaviour: the background in the first slide is lost...

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 72b099d279e7096d41a04fe8c0dd493a5fc18a33
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-07-30 12:01:36 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ee45d881efab230e7682f964d6ad4d00f85b0006

author	Justin Luth <justin.luth@collabora.com>	2018-06-25 13:43:11 +0300
committer	Szymon Kłos <szymon.klos@collabora.com>	2018-06-27 10:52:47 +0200
commit	ee45d881efab230e7682f964d6ad4d00f85b0006 (patch)
tree	3235594bd83f86ee9f1fdea3e3c56e7e4a816c9c
parent	82e5b2ba14c4d10a5ae899d5e370eaac8b2f2411 (diff)
tdf#114845 sd: only shift rotated group items
fixes 6.0 commit  9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602
> PPTX export: correct position of rotated groups

However, there was nothing excluding the re-positioning
to only group items.

Bisected with: bibisect-linux64-6.2

Adding Cc: to Justin Luth
Comment 2 Xisco Faulí 2018-07-30 12:05:28 UTC
Same behaviour observed with attachment 60731 [details] from bug 49251
Comment 3 Justin L 2018-07-30 13:02:01 UTC
Note that comment 0 and comment 2 are effectively the same document.

Confirmed, even though it seemed unlikely. However, the background hasn't actually disappeared. Zoom out and you will see if off of the bottom right corner.  Also confirmed that this was a problem up to LO 5.4, and fixed by Szymon's fix (https://cgit.freedesktop.org/libreoffice/core/commit/?id=9ae1e094d5a8a5b4432c88ebea0ca9fc1c79f602).
Comment 4 Xisco Faulí 2018-07-30 13:35:32 UTC
(In reply to Justin L from comment #3)
> Note that comment 0 and comment 2 are effectively the same document.
> 
> Confirmed, even though it seemed unlikely. However, the background hasn't
> actually disappeared. Zoom out and you will see if off of the bottom right
> corner. 

Indeed, didn't check that before...
Comment 5 Xisco Faulí 2018-07-30 13:53:02 UTC
Created attachment 143827 [details]
triangles changes position after RT
Comment 6 Xisco Faulí 2018-07-30 13:57:06 UTC
Created attachment 143828 [details]
bottom arrow changes position after RT
Comment 7 Justin L 2018-07-31 19:13:03 UTC

*** This bug has been marked as a duplicate of bug 91999 ***