Download it now!
Bug 119166 - EDITING: Creating new fields in a form with "Add Filed" crashes LO immediately
Summary: EDITING: Creating new fields in a form with "Add Filed" crashes LO immediately
Status: RESOLVED DUPLICATE of bug 118963
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 120866 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-09 09:02 UTC by Robert Großkopf
Modified: 2018-10-24 10:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["SdrObject::GetObjectItemPool() const","SdrObject::GetObjectItemPool()"]


Attachments
Open the form vor editing. Try "Add Field" - crashes whole LO immediately (11.98 KB, application/vnd.oasis.opendocument.database)
2018-08-09 09:02 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2018-08-09 09:02:09 UTC
Created attachment 144052 [details]
Open the form vor editing. Try "Add Field" - crashes whole LO immediately

Open the attached database.
Open The form for editing, not input new data.
Go to "Add Field" (6th button at the bottom).
Try to add "ID".
LO crashes immediately and creates a crashreport:
crashreport.libreoffice.org/stats/crash_details/aa5fab58-c251-46d9-8a8b-71a955415955

Could repeat this every time. Unable to add a field through "Add Field".
Tested with LO 6.1.0.3 on OpenSUSE 15, 64bit rpm Linux
Comment 1 Xisco Faulí 2018-08-09 09:16:58 UTC
Reproduced in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

http://crashreport.libreoffice.org/stats/signature/SdrObject::GetObjectItemPool()
Comment 2 Xisco Faulí 2018-08-09 09:20:49 UTC
This isssue is fixed in master by http://cgit.freedesktop.org/libreoffice/core/commit/?id=e5ee79b5c089e72e6b24c04c7c820d706bd39993

Closing as RESOLVED DUPLICATED of bug 118963

*** This bug has been marked as a duplicate of bug 118963 ***
Comment 3 Xisco Faulí 2018-10-03 15:40:19 UTC
aahh, still reproduced in

Versión: 6.1.2.1
Id. de compilación: 65905a128db06ba48db947242809d14d3f9a93fe
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

backport to 6.1 waiting for review in gerrit...
Comment 4 Xisco Faulí 2018-10-24 10:14:17 UTC
*** Bug 120866 has been marked as a duplicate of this bug. ***