Bug 119221 - FILESAVE: Fill and outline of Fontwork characters are badly exported from Impress and Calc to MS Office
Summary: FILESAVE: Fill and outline of Fontwork characters are badly exported from Imp...
Status: RESOLVED DUPLICATE of bug 100348
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2018-08-11 21:38 UTC by Regina Henschel
Modified: 2021-06-18 16:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Colored Fontwork to test export (15.24 KB, application/vnd.oasis.opendocument.presentation)
2018-08-11 21:38 UTC, Regina Henschel
Details
Export result by LibreOffice (20.83 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-08-11 21:39 UTC, Regina Henschel
Details
How PowerPoint converts from odp to pptx (48.49 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-08-11 21:41 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-08-11 21:38:20 UTC
Created attachment 144115 [details]
Colored Fontwork to test export

Enter a Fontwork in Impress or Calc with filled characters with outline. Save the file in the corresponding MS Office format. Reopen the exported file or open it in MS Office.
The outline of the character becomes a shape border line, the fill color of the characters are lost and the characters are black.

If you open the original files in MS Office and export it there to pptx or xlsx respectively, MS Office converts it so, that the characters look the same. We should do the same, to get a good user experience.

[BTW, using the Fontwork in Writer results in the correct character fill and outline. But the size of the shape is wrong.]
Comment 1 Regina Henschel 2018-08-11 21:39:00 UTC
Created attachment 144116 [details]
Export result by LibreOffice
Comment 2 Regina Henschel 2018-08-11 21:41:04 UTC
Created attachment 144117 [details]
How PowerPoint converts from odp to pptx
Comment 3 m.a.riosv 2018-08-12 11:52:45 UTC
Reproducible
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 82b12d836582c2dccc5f438363c9d128e85ac656
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-12_03:30:11
Locale: es-ES (es_ES); Calc: CL
Comment 4 Xisco Faulí 2018-08-15 16:06:19 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 QA Administrators 2021-06-18 04:02:20 UTC Comment hidden (obsolete)
Comment 6 Regina Henschel 2021-06-18 13:37:04 UTC
Export is correct in Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: e718f0e703c0fb33a0b1b5efe7b13b02c25f3335
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL
Comment 7 Xisco Faulí 2021-06-18 16:00:05 UTC
Issue fixed in

https://cgit.freedesktop.org/libreoffice/core/commit/?id=005f5db47b8e1bbd7ebddee92009be072e835fd5

author	Regina Henschel <rb.henschel@t-online.de>	2020-07-04 15:11:03 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2020-07-10 00:57:22 +0200
commit 005f5db47b8e1bbd7ebddee92009be072e835fd5 (patch)
tree dd91d9f59e17b1ae916c34db7373cd3d4f5a3ab6
parent b8ff69726959ee4d148c12866d64601d86635bcc (diff)
tdf#100348 add fill to fontwork in export to pptx

Closing as dupe of bug 100348

*** This bug has been marked as a duplicate of bug 100348 ***