Download it now!
Bug 119283 - Problem opening excelfile edited with Libreoffice calc in MS excel 2010 - warning/Damaged file...
Summary: Problem opening excelfile edited with Libreoffice calc in MS excel 2010 - war...
Status: RESOLVED DUPLICATE of bug 79998
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX-Corrupted
  Show dependency treegraph
 
Reported: 2018-08-15 07:38 UTC by sverre48
Modified: 2018-08-16 09:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (16.82 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-08-15 11:48 UTC, Xisco Faulí
Details
Sample ODS with 32-character sheet name (7.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-08-15 23:31 UTC, Aron Budea
Details
Sample XLSX saved from the ODS (4.27 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2018-08-15 23:34 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sverre48 2018-08-15 07:38:00 UTC
Description:
On August 10 I edited an xlsx file in latest libreoffice release. The file was based on an earlier file. In Libreoffice calc it works fine but when trying to open it in MS office excel 2010 - it issues a warning (file corrupt)
https://www.dropbox.com/s/otmw5qtfpi2j3yt/M%C3%A5lscorere%20og%20resultater%2C%202018-19%20-%20Copy.xlsx?dl=0



Steps to Reproduce:
1. Download file
https://www.dropbox.com/s/otmw5qtfpi2j3yt/M%C3%A5lscorere%20og%20resultater%2C%202018-19%20-%20Copy.xlsx?dl=0
2. Open the file in MS office (I used office 2010)
3. Warning is issued...
https://www.dropbox.com/s/n6imml6joravte3/Open%20file%20in%20Office%20problem.png?dl=0

Actual Results:
See step 3 above (this problem) - anomaly - se https://www.dropbox.com/s/n6imml6joravte3/Open%20file%20in%20Office%20problem.png?dl=0

Expected Results:
No warning! Compatibility - please!


Reproducible: Always


User Profile Reset: No



Additional Info:
Opening error
https://www.dropbox.com/s/n6imml6joravte3/Open%20file%20in%20Office%20problem.png?dl=0
Comment 1 Timur 2018-08-15 11:28:30 UTC
Attachments need to be added, no Dropbox links. 
Please write precisely, not "in latest libreoffice release" but "in LO 6.0.6.2" if that's the case. 
https://bugs.documentfoundation.org/show_bug.cgi?id=117606#c4
Comment 2 sverre48 2018-08-15 11:36:23 UTC
Well, I use the latest off. release, 6.1...
Comment 3 Xisco Faulí 2018-08-15 11:48:03 UTC
Created attachment 144185 [details]
sample file
Comment 4 Xisco Faulí 2018-08-15 11:52:04 UTC
Did it happen to you with previous versions of LibreOffice?
OTOH, Could you please attach the original document before saving it in LibreOffice?
Comment 5 sverre48 2018-08-15 17:44:02 UTC
Well, the excel file contains the fixtures in the premier league for the 2018-19 season and is based on this file
https://www.dropbox.com/s/51m7ic5aw9egq2x/Lukaku%2C%202017-18.xlsx?dl=0

which opens as expected in excel 2010. Here there is a new sheet containing the matches from round 1 to 38 for a certain team. This was created around August 10 - using the latest official Libreoffice calc at that time and uploaded/shared using dropbox.

So I am not able to find/pin point what causes excel 2010 (and other Microsoft releases) to issue the opening file warning (damaged file). 

So I updated the new file/document only using release 6.1.03 and only have one release available at any time, i.e. always the latest one released
Comment 6 sverre48 2018-08-15 17:50:51 UTC
On a second thought, I think the cause again is a too long sheet name. I renamed it to see if that works from
Målscorere og terminliste, 2018-19
Målscorere-terminliste, 2018-19
0123456789012345678901234567890123

New link
https://www.dropbox.com/s/yrzvwyp47zr673v/M%C3%A5lscorere%20og%20resultater%2C%202018-19.xlsx?dl=0
Comment 7 Aron Budea 2018-08-15 23:31:39 UTC
Created attachment 144215 [details]
Sample ODS with 32-character sheet name

Indeed, here's an extremely simple sample with nothing, but a 32-character sheet name. Save it as XLSX in Calc, and try opening it in Excel.

No problem with a 31-character name.
Comment 8 Aron Budea 2018-08-15 23:34:25 UTC
Created attachment 144216 [details]
Sample XLSX saved from the ODS

This is the same file saved as XLSX in LO 6.1.0.3 that fails to open in Excel.
Comment 9 sverre48 2018-08-16 06:30:46 UTC
Not really same file - as the last file link shows, the first sheet name is renamed to a shorter than max 30-32 chars length - which works fine with Excel 2010. What is the status of this sticky flaw? Should be easy to trap and prevent the incompatibility
https://bugs.documentfoundation.org/show_bug.cgi?id=117606
Comment 10 Xisco Faulí 2018-08-16 08:19:05 UTC
Dupe of bug 79998

*** This bug has been marked as a duplicate of bug 79998 ***