Bug 119293 - UI Consistency for inserting rows in Writer table
Summary: UI Consistency for inserting rows in Writer table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Cell-Management
  Show dependency treegraph
 
Reported: 2018-08-15 12:03 UTC by Scott Pritchett
Modified: 2018-09-13 15:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Inserting Rows (29.28 KB, image/jpeg)
2018-08-15 12:05 UTC, Scott Pritchett
Details
Before and After (19.20 KB, image/jpeg)
2018-08-15 12:06 UTC, Scott Pritchett
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Pritchett 2018-08-15 12:03:12 UTC
Description:
The rows insert dialog is inconsistent. Having inserted a table. Right-click select Insert, shows Rows Above and Rows Below, whereas selecting Rows shows Position as Before and After, the same letters A and B meaning the opposite.

Steps to Reproduce:
1.Insert table
2.Right-Click on a cell
3.Insert 

Actual Results:
UI inconsistency. Rows Above, Rows Below, [Rows] After, [Rows] Before. 

Expected Results:
Pick one and stick with it


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Scott Pritchett 2018-08-15 12:05:34 UTC
Created attachment 144191 [details]
Inserting Rows
Comment 2 Scott Pritchett 2018-08-15 12:06:26 UTC
Created attachment 144193 [details]
Before and After
Comment 3 Heiko Tietze 2018-08-22 18:53:13 UTC
Sounds reasonable, taking it.
Comment 4 Thomas Lendo 2018-08-22 22:04:05 UTC
Above/below/left/right sounds good. I prefer to replace before and after as that's also not clear if it means verical or horizontal action.
Comment 5 Heiko Tietze 2018-08-23 09:21:50 UTC
The dialog [1] is used for both, rows and columns. That means Above/Below would be wrong in case of columns. Can we live with Before/After in that regards?

[1] cui/uiconfig/ui/insertrowcolumn.ui
Comment 6 Heiko Tietze 2018-08-31 08:47:07 UTC
Scott, what do you think?
Comment 7 Scott Pritchett 2018-08-31 10:57:22 UTC
If there’s no chance of having different dialog wording or two separate dialogs then I, personally, wouldn’t mind Before & After for both rows & columns. Then the keyboard shortcut keys could be made consistent too.
Comment 8 Heiko Tietze 2018-08-31 12:29:07 UTC
I think the shortcuts are clear. Let's go with some code and set the label to "Left of the selection" and "Above the selection" resp. right/below with code.

https://gerrit.libreoffice.org/#/c/59867/
Comment 9 Commit Notification 2018-09-03 07:06:34 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a3c8250c5b56a2cb40aa01b9a6a59e4daa1fd2f8

tdf#119293 - UI Consistency for inserting rows in Writer table

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-09-06 08:44:15 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48d7a087b43b523d9d3f2bb296904c5a4ef43759

Revert "tdf#119293 - UI Consistency for inserting rows in Writer table"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Heiko Tietze 2018-09-06 09:44:28 UTC
Reverted the patch since Left is wrong on RTL formatted tables. We now use Before/After like on Calc. Sorry for the noise.
Comment 12 Commit Notification 2018-09-06 13:32:34 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=77a9df09adfcb04a3d49a621d568694657969fd7

tdf#119293 - UI Consistency for inserting rows in Writer table"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Thomas Lendo 2018-09-13 15:05:08 UTC
Verified.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 18c5089df091bddeb8c2dc339776671964389040
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-12_23:24:12
Locale: de-AT (de_AT); Calc: CL