Bug 119295 - Blue text selection starts blinking on mouse movement under certain conditions (especially with trackpad)
Summary: Blue text selection starts blinking on mouse movement under certain condition...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Main-Loop
  Show dependency treegraph
 
Reported: 2018-08-15 12:12 UTC by Telesto
Modified: 2022-06-02 20:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Bibisect log (5.19 KB, text/plain)
2018-08-15 12:25 UTC, Telesto
Details
Example file (22.88 KB, application/vnd.oasis.opendocument.text)
2018-08-26 09:14 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-15 12:12:24 UTC
Description:
Blue text selection starts blinking on mouse movement under certain conditions (especially with trackpad)

Steps to Reproduce:
1. Open the attached file
2. Select the text in A1 - the content not the cell from top left to bottom right
3. Go outside the table & move the mouse around while holding still holding the left mouse click
4. Blue text selection starts blinking as crazy
5. Remove the embedded table in B1
6. Do the same again (everything is fine)

Actual Results:
Blue text selection starts blinking as crazy

Expected Results:
Shouldn't happen 


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: c0fdcece6b886912618deee9656cb2d169a9b999
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-12_00:35:45
Locale: en-US (nl_NL); Calc: CL

and in
Version: 6.0.0.1.0+
Build ID: 47cc374c0659fd3db74a1b184c870eaa56bc385b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL

but not with
Version: 5.4.1.0.0+
Build ID: f200d5700782ae179fd96b6ad4b0fe8e7edd1616
CPU threads: 4; OS: Windows 6.29; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Telesto 2018-08-26 09:14:22 UTC
Created attachment 144445 [details]
Example file

I forgot to add the example. This is a different one, with the same issue

Enter cell B1 & select the content above the embedded table. Deselect a part of the content, word for word, line for line. It's blinking

Same happens in A1. But not in A2 or B2
Comment 3 Buovjaga 2018-09-20 10:02:17 UTC
Hmm, strange that you were able to bibisect with 5.0 repo... We got different results.

Bibisected with win32-6.0 to https://cgit.freedesktop.org/libreoffice/core/commit/?id=50799a721c7ddcf9475a1b79984ed64ddd7cdf57

tdf#109997 WIN don't post a callback event directly

Adding Cc: to Jan-Marek Glogowski

Repro also on Linux. The old selecting behaviour feels slower, though.
Comment 4 Buovjaga 2018-09-20 10:02:42 UTC
(In reply to Buovjaga from comment #3)
> Hmm, strange that you were able to bibisect with 5.0 repo... We got
> different results.
> 
> Bibisected with win32-6.0 to
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=50799a721c7ddcf9475a1b79984ed64ddd7cdf57
> 
> tdf#109997 WIN don't post a callback event directly
> 
> Adding Cc: to Jan-Marek Glogowski
> 
> Repro also on Linux. The old selecting behaviour feels slower, though.

Forgot to add CC
Comment 5 Jan-Marek Glogowski 2018-09-20 10:33:32 UTC
(In reply to Buovjaga from comment #3)
> Hmm, strange that you were able to bibisect with 5.0 repo... We got
> different results.
> 
> Bibisected with win32-6.0 to
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=50799a721c7ddcf9475a1b79984ed64ddd7cdf57
> 
> tdf#109997 WIN don't post a callback event directly
> 
> Adding Cc: to Jan-Marek Glogowski
> 
> Repro also on Linux.

This change is Windows only (that's why it starts with WIN).
If you can reproduce it on Linux, it can't be this change.

> The old selecting behaviour feels slower, though.

That was the point of all the Scheduler rework. I don't remember how many bugs were covered by slow LO behavior.

My guess would be that this bug has always been there, but the slowness covered it. And a paint event is processed too early, before repaint is finished for whatever reason.
Comment 6 QA Administrators 2019-09-21 03:07:52 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2021-09-21 04:52:44 UTC Comment hidden (obsolete)
Comment 8 Gabor Kelemen (allotropia) 2022-06-02 20:59:13 UTC
I can't reproduce this flickering anymore in 7.3, bibisect-7.3-linux (same on bibisect-7.3-win) shows:

https://git.libreoffice.org/core/+/b9c2207e1b5247b4d3184b137be9a75a4b8c6c37

author	Luboš Luňák <l.lunak@collabora.com>	Mon Aug 09 12:44:40 2021 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	Wed Sep 08 10:31:03 2021 +0200


avoid repeated writer layout calls with tiled rendering

Thanks Luboš for fixing this!