Bug 119403 - Draw measurement line didn't work
Summary: Draw measurement line didn't work
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-21 15:37 UTC by andreas_k
Modified: 2019-06-08 20:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-08-21 15:37:55 UTC
when you use in draw measurement line the text label didn't work in master. When you use writer it will work correct also in 6.1 it work correct in draw but not in master.

Fix is needed for measurement line text label in draw.
Comment 1 andreas_k 2018-08-21 16:25:00 UTC
reproduce:

1. LibreOffice master (21.08.2018)
2. Start Draw
3. Drawing Toolbar -> Lines and Arrows dropdown items -> Dimension Line
4. Draw an dimension line didn't show the dimension line label

5. Start Writer
6. View -> Toolbar -> Drawing
7. Drawing Toolbar -> Lines and Arrows dropdown items -> Dimension Line
8. Draw an dimension line show the dimension line label
Comment 2 Drew Jensen 2018-08-21 17:00:08 UTC
Confirmed with Ubuntu 18.04 LibreOffice 6.2 Alpha

Running bibisect against the current daily repo (6.2 and updated just now) didn't yield any version that did not have this anomaly. 

Starting the bibsect against the 6.1 repo.
Comment 3 Drew Jensen 2018-08-21 17:07:00 UTC
Well, running bibisect against the 6.1 repository didn't make it any clearer either. Not a single iteration showed the anomaly.
Comment 4 Drew Jensen 2018-08-21 17:09:14 UTC
Also I checked 6.2 ALpha with both 
SAL_USE_VCLPLUGIN=gen and SAL_USE_VCLPLUGIN=gtk as startup options.

No difference, both have the anomaly.
Comment 5 BogdanB 2018-08-21 17:25:46 UTC
I bibisect with 6.1 on linux: works well on each version 

3a5db37fadb4477261591bcae629661d527a3069 is the first bad commit
commit 3a5db37fadb4477261591bcae629661d527a3069
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Aug 3 13:29:08 2018 +0200

    source sha:8ed224599ae7985b577f0bf737b2b9b2e8dd47b7
    
    source sha:8ed224599ae7985b577f0bf737b2b9b2e8dd47b7

:040000 040000 cb0879725df27b906878272d2764d47bee2f969e 164869d2abff25f52e230da69f1a08283e9cdca5 M	instdir
Comment 6 BogdanB 2018-08-21 17:28:07 UTC
I can reproduce on Version: 6.2.0.0.alpha0+
Build ID: f05b0a6aaf8af5d78f9cad8bb953228cb0ce09f1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-20_01:57:14
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 7 Maxim Monastirsky 2018-08-21 20:09:28 UTC

*** This bug has been marked as a duplicate of bug 118203 ***
Comment 8 Heiko Tietze 2018-08-22 11:48:13 UTC
(In reply to Maxim Monastirsky from comment #7)
> 
> *** This bug has been marked as a duplicate of bug 118203 ***

Andreas wants to provide measure lines in Writer with this issue, while Regina asks for a UI at Draw in the other ticket.
Comment 9 BogdanB 2018-08-22 12:18:50 UTC
Working on:
Version: 6.2.0.0.alpha0+ (x64)
Build ID: ac7a655f614175353445d99e8550b66936613c21
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-14_02:18:26
Locale: ro-RO (ro_RO); Calc: threaded

It is working very well on:
Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: ro-RO (ro_RO); Calc: group threaded
Comment 10 Maxim Monastirsky 2018-08-22 13:31:58 UTC
(In reply to Heiko Tietze from comment #8)
> (In reply to Maxim Monastirsky from comment #7)
> > 
> > *** This bug has been marked as a duplicate of bug 118203 ***
> 
> Andreas wants to provide measure lines in Writer with this issue,
There are already measure lines in Writer since 5.3 (see Bug 101390)

> while Regina asks for a UI at Draw in the other ticket.
Well, the 'Component' field of this bug is also set to 'Draw', and the description (in both comment 0 and comment 1) clearly talks about the missing label in Draw, which is a duplicate of Bug 118203.

Anyway, I'll set to NEEDINFO and let Andreas clarify what this bug is about.
Comment 11 Xisco Faulí 2018-08-23 08:44:15 UTC
Hi Andreas,
Please reply to Maxim comment 10 and set the status back to NEW otherwise this issue will get lost in the sea of NEEDINFO bugs...
Comment 12 QA Administrators 2019-03-21 11:10:53 UTC Comment hidden (obsolete)
Comment 13 BogdanB 2019-03-24 07:18:19 UTC
Working on master now...

Version: 6.3.0.0.alpha0+
Build ID: a03f421a878c210566dc8d728113a27400da38f2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-16_09:07:41
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded

Andreas_k, please test it.
Comment 14 Thomas Lendo 2019-06-08 20:28:44 UTC
I also don't see any difference in Writer and Draw.

Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US

Closing as WORKSFORME as Andreas is very active in the community but hasn't answered for 10 months. If there is an issue, he can respond anytime.