Bug Hunting Session
Bug 119444 - After installing LibreOffice 6.1.0.3 (x64) in Windows 10 most of the icons are obscured for Colibre, Elementary and Tango
Summary: After installing LibreOffice 6.1.0.3 (x64) in Windows 10 most of the icons ar...
Status: RESOLVED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2018-08-23 09:59 UTC by Tonyab
Modified: 2018-08-28 14:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (74.54 KB, image/png)
2018-08-23 10:09 UTC, Tonyab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tonyab 2018-08-23 09:59:16 UTC
Description:
After installing LibreOffice 6.1.0.3 (x64) I notice that most of the application icons are obscured. It is an uncomfortable vision that forces to uninstall the new version.

This obscured vision does not happen with the rest of the applications installed on the computer or with the previous versions of LibreOffice.

Steps to Reproduce:
1. Install LibreOffice 6.1.0.3 (x64)
2. Open any LibreOffice application
3. Observe appearance of the icons

Actual Results:
I notice that most of the application icons are obscured. The icons appear practically black.

Expected Results:
Show icons with a normal appearance.


Reproducible: Always


User Profile Reset: No



Additional Info:
SO: Windows 10 Home (c) 2016 | Computer: Intel (R) Core(TM) i5-7200U | Intel (R) HD Graphics | LibreOffice: Version 6.1.0.3 (x64) - Id. compilation: efb621ed25068d70781dc026f7e9c5187a4decd1
Comment 1 Tonyab 2018-08-23 10:09:17 UTC
Created attachment 144386 [details]
Screenshot
Comment 2 Tonyab 2018-08-23 19:31:05 UTC
There is no error. LibreOffice version 6.1.0.3 has an icon style configured in automatic mode called "Colibre" with a strange design that looks like erroneous icons. This configuration of icons that appear automatically (by default) represent a bad choice of icons (low marketing vision). Resolved, I'm glad that this was the problem. I suggest changing the icons by default.
Comment 3 Tonyab 2018-08-24 09:17:18 UTC
Effectively, Colibre's icon style is not the one that appeals to me. I have verified it on another computer with another previous version of Windows 10 (1709) and with Linux Mint 19 and it appears correctly. The problem is in my computer or in the version of W10 that it employs.

I am sorry to insist on this issue but it seems important to me since I usually advise other users to install LibreOffice and I have to have all the information so that these circumstances do not happen.
Comment 4 Timur 2018-08-24 10:59:59 UTC
Could you please clarify what you expect?
Comment 5 andreas_k 2018-08-24 11:08:30 UTC
This look a bit like you want to use high contras.
Comment 6 V Stuart Foote 2018-08-24 11:50:45 UTC
We have seen similar issues on Windows systems with Intel GPUs running in OpenGL rendering mode with Intel drivers that are not fully updated.

Do things improve if you set the rendering mode for LibreOffice by unchecking:

Tools -> Options -> View : "Use OpenGL for All Rendering"

and restarting LibreOffice?

If so, a graphics driver update may resolve things, or you may need to avoid using the OpenGL rendering.
Comment 7 Tonyab 2018-08-24 12:35:11 UTC
(In reply to Timur from comment #4)
> Could you please clarify what you expect?

The default icon style "Colibre" is not displayed properly. You can see the screenshot attached to the first comment.
Comment 8 Tonyab 2018-08-24 12:36:57 UTC
(In reply to andreas_k from comment #5)
> This look a bit like you want to use high contras.

It has disabled any option of high contrast and remains the same.
Comment 9 Tonyab 2018-08-24 12:55:48 UTC
(In reply to V Stuart Foote from comment #6)

Thank you very much, interesting contribution but ... I updated the driver for my Intel (R) HD Graphics 620 today and installed all the Windows 10 updates. I have unchecked OpenGL. The icons still fail.

I will experiment with different operating systems with VirtualBox, I suspect that some icon extension recently used by developers is not compatible with Windows or Intel. The strange thing is that it does not happen with any other program or with the previous version of LibreOffice (6.0.6)

I clarify that it is a computer of recent acquisition so the problem could arise in current computers although I really do not find much logic. I have also observed problems in the icons of other LibreOffice styles incorporated in the new version 6.1.0.3.
Comment 10 Tonyab 2018-08-24 14:32:47 UTC
I have updated Windows 10, the Intel graphics card and unmarked OPenGL (for advice) and the Colibre icons continue to fail. It also affects other styles although to a lesser extent. However,  I have simulated Linux Mint 19 on the same computer with VirtualBox and  installed LibreOffice 6.1.0.3 and the icons are perfect. I suspect that the problem is related to an update of Windows 10, a file format (icons) not allowed by Windows 10 or simply new problems of compatibility of LibreOffice with Windows 10. I remain interested in new contributions to solve the mystery of the icons.
Comment 11 V Stuart Foote 2018-08-24 15:46:55 UTC
So, are the other LibreOffice icon themes under your Windows 10 desktop affected as well?

From Tools -> Options -> View : Icon style  dropdown, please select a different colored icon theme, I'd suggest a test fo the new "Karasa Jaga" icons as they are richly colored more so than Colibre.

Are those icons also misrendered?
Comment 12 andreas_k 2018-08-24 15:58:52 UTC
I would be also interested if its effects other themes too.
Comment 13 Tonyab 2018-08-24 16:52:54 UTC
(In reply to V Stuart Foote from comment #11)

I have carried out a test of displaying styles of icons on the same computer under two different operating systems. In Windows 10 the following styles (themes) are displayed correctly: Breeze, Breeze Dark Karasa Jaga, Sifr and Sifr Dark; however, the styles that are displayed badly are: Colibre, Elementary and Tango. In Linux Mint 19 all the icons are displayed correctly.
Comment 14 Tonyab 2018-08-24 16:54:26 UTC
(In reply to andreas_k from comment #12)

Thank you very much for your answers, I have answered your question in comment #13.
Comment 15 Tonyab 2018-08-24 17:04:34 UTC
I think the problem must be in some format of files used for the design of icons that are not read or recognized correctly under Microsoft Windows 10 beside the Intel graphics card. Current updates of both still do not pick up this problem.
Comment 16 V Stuart Foote 2018-08-24 17:49:39 UTC
We will assume that you have reset you LibreOffice user profile. If not, done from Help -> Restart in Safe Mode, and from the dialog choose the "Reset to factory settings" & "Reset entire user profile"

Otherwise...

(In reply to akatonyab from comment #15)
> I think the problem must be in some format of files used for the design of
> icons that are not read or recognized correctly under Microsoft Windows 10
> beside the Intel graphics card. Current updates of both still do not pick up
> this problem.

Unlikely to have anything to do with the icons themselves (either SVG or PNG cache). You are the first and only report of this issue on any Windows OS suggesting the issue is with _your_ windows installation. 

Are you by chance using some 3rd party theme for your Windows desktop environment?
Comment 17 Tonyab 2018-08-24 18:56:01 UTC
(In reply to V Stuart Foote from comment #16)

I do not observe this problem in any other installed application (GIMP, INKSCAPE, PYTHON, VLC, ...), likewise there is no problem in the previous version of LibreOffice (6.0.6). The computer is a recent acquisition with Windows 10 installed and I do not use any third party theme for my windows desktop. In any case, if the problem is unique, it is not necessary to invest more time in it. If at any time you appreciate other irregular behavior, I would appreciate LibreOffice taking it into account. At the moment I will use the Sifr style that is displayed correctly while I find out what problem exists on my computer with the rest of the styles. The same thing in the next version everything works fine on my computer. Thank you so much for everything.
Comment 18 Timur 2018-08-28 08:29:03 UTC
Do you have HDPI display, is this a duplicate of Bug 119020?
Comment 19 V Stuart Foote 2018-08-28 12:39:51 UTC
(In reply to Timur from comment #18)
> Do you have HDPI display, is this a duplicate of Bug 119020?

Good point! 


For HiDPI support we shift in the SVG version icons, which then must respond to the scaling setting of Windows. 

@akatonyab@gmail.com, is your new Windows system a HiDPI screen, i.e. > ~150 dpi? I think we use 168dpi as the cut over. Personally, I've no issues with 96dpi to ~130dpi.
Comment 20 Tonyab 2018-08-28 13:23:25 UTC
(In reply to Timur from comment #18)

I'm happy to see Bug 119020, I'm not the only one. I have varied the properties reported in that error and solved the problem. You are a genius, thank you very much.

About what you asked me leaves the information I have available in case it is useful for later development. 

Display: 13,3" Full HD display with 1.920 x 1.080 pixel Tech IPS
Color format: RGB
Space of colors: Standard dynamic range (SDR)
Comment 21 Tonyab 2018-08-28 13:26:41 UTC
(In reply to V Stuart Foote from comment #19)

Thank you very much the problem has been solved from the properties of the Writer icon. Solved with the scaling setting of Windows. The problem was in HDPI Display.

About what you asked me leaves the information I have available in case it is useful for later development. 

Display: 13,3" Full HD display with 1.920 x 1.080 pixel Tech IPS
Color format: RGB
Space of colors: Standard dynamic range (SDR)(In reply to V Stuart Foote from
Comment 22 V Stuart Foote 2018-08-28 14:08:25 UTC
(In reply to akatonyab from comment #21)
> (In reply to V Stuart Foote from comment #19)
> 
> Thank you very much the problem has been solved from the properties of the
> Writer icon. Solved with the scaling setting of Windows. The problem was in
> HDPI Display.
> 
> About what you asked me leaves the information I have available in case it
> is useful for later development. 
> 
> Display: 13,3" Full HD display with 1.920 x 1.080 pixel Tech IPS
> Color format: RGB
> Space of colors: Standard dynamic range (SDR)(In reply to V Stuart Foote from

OK, that would be 165.6 dpi, that puts you right at the HiDPI cut over--but seems the key is the Windows DE scaling applied to the icon theme.

*** This bug has been marked as a duplicate of bug 119020 ***