Bug 119478 - FILEOPEN: Draw document (.odg) opens in Impress from recent Documents (see comment 6)
Summary: FILEOPEN: Draw document (.odg) opens in Impress from recent Documents (see co...
Status: RESOLVED DUPLICATE of bug 65017
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SD-Shared-Code
  Show dependency treegraph
 
Reported: 2018-08-24 12:36 UTC by Kohei Yoshida
Modified: 2018-12-05 20:43 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2018-08-24 12:36:28 UTC
Description:
Opening a .odg file without specifying the file format type now opens in Impress instead of in Draw.

Steps to Reproduce:
1. Create a odg document in Draw and save it to disk.
2. Close and open LibreOffice Draw.
3. Open the file you just saved.
4. It opens it in Impress.

Actual Results:
The file opens in Impress.

Expected Results:
The file is expected to be opened in Draw.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Kohei Yoshida 2018-08-24 12:39:41 UTC
The workaround for me for now is to open the fileopen dialog, select the file, then set the file type to "ODF Drawing (*.odg)".  I've noticed there is "ODF Drawing (Impress) (*.odg)" in the drop-down menu.  I wonder if that filter type is selected instead...
Comment 2 Buovjaga 2018-08-24 13:11:10 UTC
No repro.

Did you try in Safe mode?

Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: fi-FI (fi_FI); Calc: group threaded
Comment 3 Aron Budea 2018-08-24 13:35:12 UTC
No repro with LO 6.1.0.3 & 6.2 daily build (2018-08-17_00:41:06, 380d0fda99ff664de8443cfc33c7c86bca18134c) / Windows 7.
File opens in Draw upon opening it without format selection.
Comment 4 Xisco Faulí 2018-08-24 16:07:30 UTC
I can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: e78a6c4231cfb33643b45442b786e1e31b2781a8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 5 Buovjaga 2018-08-24 17:55:54 UTC
Kohei said he had reset the profile.
Comment 6 Kohei Yoshida 2018-08-24 18:03:34 UTC
Try having a Impress document open first.  Then from the Open icon drop-down menu of Impress, select a Draw document (.odg) from the list of recent documents.
Comment 7 Buovjaga 2018-08-24 18:06:14 UTC
(In reply to Kohei Yoshida from comment #6)
> Try having a Impress document open first.  Then from the Open icon drop-down
> menu of Impress, select a Draw document (.odg) from the list of recent
> documents.

Repro.

Adding Cc: to Armin Le Grand. What do you think?

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: d30e76eb7854e9a4f170677719ad0ac3f92ef297
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on August 23rd 2018
Comment 8 Xisco Faulí 2018-08-25 15:12:12 UTC
I can reproduce it back to

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: defaul

but not in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

it need to be bisected with 5.1 repo...
Comment 9 Aron Budea 2018-08-25 17:35:11 UTC
Bibsected to the following commit using repo bibisect-win32-5.1. Considering the commit is only an addition to another commit referenced in the commit message, likely the problem originated from the referenced commit.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8655fa318c1924994eb659b4bb60074c86ad70c1
author		Maxim Monastirsky <momonasmon@gmail.com>	2015-11-08 01:33:47 +0200
committer	Maxim Monastirsky <momonasmon@gmail.com>	2015-11-08 10:47:10 +0200

"Fix property name: ModuleName -> ModuleIdentifier"


https://cgit.freedesktop.org/libreoffice/core/commit/?id=8b050d1e91a6623fb2770421e564a74d6259d816
author		Ariel Constenla-Haile <arielch@apache.org>	2013-04-26 21:55:57 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2013-05-21 16:29:33 +0100

"UI Controller Factory fixes"
Comment 10 Maxim Monastirsky 2018-12-05 20:43:19 UTC
(In reply to Aron Budea from comment #9)
> Bibsected to the following commit using repo bibisect-win32-5.1. Considering
> the commit is only an addition to another commit referenced in the commit
> message, likely the problem originated from the referenced commit.
Actually the problem originated from a different commit, see Bug 121128 comment 7.

*** This bug has been marked as a duplicate of bug 65017 ***