Download it now!
Bug 119496 - LibreCalc - Cell border drawing issue, when the neighbour column is hidden
Summary: LibreCalc - Cell border drawing issue, when the neighbour column is hidden
Status: RESOLVED DUPLICATE of bug 116051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Cell-Border Regressions-borderline
  Show dependency treegraph
 
Reported: 2018-08-25 20:37 UTC by Zsolt Pálfi
Modified: 2018-10-29 18:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zsolt Pálfi 2018-08-25 20:37:16 UTC
Description:
In LibreOffice 6 the cell borders are not visible, if their neighbour cells are in hidden column, even though the borders are set to the visible cell.

Note: it was correct in LibreOffice 5

Steps to Reproduce:
- Create New LibreCalc document
- Set wide border for each side of B2 cell
- Hide C column


Actual Results:
Border is missing between B2&D2

Expected Results:
Visible border between B2&D2


Reproducible: Always


User Profile Reset: No



Additional Info:
Verzió: 6.0.5.2
Build az.: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU szálak: 8; OS: Windows 10.0; Felületmegjelenítés: GL; 
Területi beállítások: hu-HU (hu_HU); Calc: CL
Comment 1 Drew Jensen 2018-08-25 21:39:30 UTC
Confirmed using Ubuntu 18.04 LibreOffice 6.0 thru 6.2 and not there in 5.4.7

Off to bibisect in 6.0 repo.
Comment 2 Drew Jensen 2018-08-25 22:04:33 UTC
bibisect shows that the anomaly arrived with commit:

a9c59cbfb9e16469b389db0b4d6befe196d0e2a0

borderline: Preparing further to use CellCoordinateSystem

Multiple cleanups, made svx::frame::Style a std::shared_ptr class,
preparing basing all border stuff on transformations, so it will
need a CellCoordinateSystem. Added stuff to get this Coordinate
System from the svx::frame::Cell using the Frame and knowledge
about ownerships

effects 6 files.

Author: Armin Le Grand (adding to CC)
Comment 3 Xisco Faulí 2018-10-29 18:50:26 UTC
Still reproducible in

Version: 6.2.0.0.alpha1+
Build ID: 19a0698079fbba36646a2d06eaec3a7fde60b2f5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

Adding Cc: to Armin Le Grand
Comment 4 Xisco Faulí 2018-10-29 18:51:27 UTC
Actually it has been already reported in bug 116051.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 116051 ***