Bug 119564 - [BASE] Copy/Paste problem with hidden column in Table
Summary: [BASE] Copy/Paste problem with hidden column in Table
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.4
Keywords:
Depends on:
Blocks: Database-Tables
  Show dependency treegraph
 
Reported: 2018-08-28 13:38 UTC by Jean-Sebastien Bevilacqua
Modified: 2021-05-27 05:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Base test file (12.58 KB, application/vnd.oasis.opendocument.database)
2018-08-28 13:38 UTC, Jean-Sebastien Bevilacqua
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sebastien Bevilacqua 2018-08-28 13:38:23 UTC
Created attachment 144513 [details]
Base test file

Hello,

I found a problem with copy/paste in Base.

Step to reproduce:

1 - Open the attached odb file
2 - Open the Table Contacts
3 - Hide the column "Nom"
4 - In the column "Prenom", right-clic on "Jean" and "Copy"
5 - Paste in a blocnote, you will see "La Feuille" instead of "Jean"

If you left-clic on the cell before the paste, there is no problem.
The problem appears only when you directly right-clic on a cell without selecting it before.

Jean-Sébastien
Comment 1 Jean-Sebastien Bevilacqua 2018-08-28 14:47:42 UTC
Reproduced on master
Comment 2 Xisco Faulí 2018-08-29 09:10:55 UTC
I can't reproduce it in

Versión: 6.1.0.3
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; 
Configuración regional: es-ES (es_ES); Calc: group threaded

nor in

Version: 6.2.0.0.alpha0+
Build ID: a922f56cbf25f78534cd2d36bf13a86a4f15d970
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: el-GR (ca_ES.UTF-8); Calc: threaded

Could you please paste the info from Help - about LibreOffice ?
Comment 3 Jean-Sebastien Bevilacqua 2018-08-29 11:14:34 UTC
Hello Xisco,

Are you sure you're not left-clicking before the copy ?
When you right-click, you should only see the copy action, if you left-click and the right-click, you will see more option than copy (like paste).
Comment 4 Xisco Faulí 2018-08-29 12:06:42 UTC
(In reply to Jean-Sebastien Bevilacqua from comment #3)
> Hello Xisco,
> 
> Are you sure you're not left-clicking before the copy ?
> When you right-click, you should only see the copy action, if you left-click
> and the right-click, you will see more option than copy (like paste).

Oh, I see. Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 3bd8316718fdfed454c01a9c4ae6af6beb34437d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded
Comment 5 Xisco Faulí 2018-08-29 12:09:30 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 6 rking 2018-09-25 13:43:44 UTC
Hi Xisco,
I've submitted a patch that implements the algorithm that allows the
recomputing of the correct Id in order to point to the correct string
viewed in the cell grid.

Change 60975
Comment 7 Commit Notification 2018-10-10 12:50:43 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f792ac91fdaaea1df38e64833dd1c258bb41c03

tdf#119564 column id is not always the same as position

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2018-10-11 08:02:00 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=21fc0ce61a25a7ab6f9bb83cecfd880f17033c4e&h=libreoffice-6-1

tdf#119564 column id is not always the same as position

It will be available in 6.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-11-12 12:19:48 UTC
A polite ping to Lionel Elie Mamane:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 10 Xisco Faulí 2018-12-18 15:38:43 UTC
(In reply to Xisco Faulí from comment #9)
> A polite ping to Lionel Elie Mamane:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

ping ?
Comment 11 Xisco Faulí 2019-05-27 14:58:57 UTC
Dear rking,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 12 QA Administrators 2021-05-27 05:01:36 UTC
Dear Jean-Sebastien Bevilacqua,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug