Bug 119642 - Writer: Solid fill in 2007 DOCX text box shape imported separately and overlies the text (also if resaved in new MSO)
Summary: Writer: Solid fill in 2007 DOCX text box shape imported separately and overli...
Status: RESOLVED DUPLICATE of bug 107428
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-09-02 00:27 UTC by ebrian_dale
Modified: 2018-09-19 23:05 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
original Word document for opening in LO Writer (1.76 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-09-02 00:34 UTC, ebrian_dale
Details
LO saved version of .docx (910.96 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-09-02 00:36 UTC, ebrian_dale
Details
pdf of original Word document (320.12 KB, application/pdf)
2018-09-02 13:02 UTC, ebrian_dale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ebrian_dale 2018-09-02 00:27:52 UTC
Description:
An a Australinn Govt document in Word docx format is opened by LO Writer 6 but prodices a scrambled and largely unreadable mess. The same document is opened perfectly in Word 2016.

Steps to Reproduce:
1. open document in LO Writer
2. open same document in Word 2016 
3. compare the two


Actual Results:
mostly unreadable document in LO Writer, normal looking document in Word 2016

Expected Results:
readable document laid out as version opened in Word 2016


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-AU (en_AU); Calc: CL
Comment 1 ebrian_dale 2018-09-02 00:34:09 UTC
Created attachment 144603 [details]
original Word document for opening in LO Writer

As downloaded from https://treasury.gov.au/consumer-data-right/

"Consumer Data Right Handout" -DOCX 2MB
Comment 2 ebrian_dale 2018-09-02 00:36:37 UTC
Created attachment 144604 [details]
LO saved version of .docx

As opened and saved by my version of LO Writer
Comment 3 Dieter 2018-09-02 08:41:50 UTC
Yes, it looks terrible, but I think it is necsessary to narrow the problem down and to describe it more precise.
Comment 4 ebrian_dale 2018-09-02 13:02:50 UTC
Created attachment 144611 [details]
pdf of original Word document

I note the comments requiring more detail and hope the additional info here helps. 

The attached pdf shows the original Word document downloaded from the website for easier comparison with the version produced by LO6. I can confirm by comparison with the MS Word version opened in MS Word, that the pdf is accurate. 

The faults in the LO version are:
- On the first page of the LO version, the blue background behind the "save on your banking..." section overlies the text instead of being a background. 
- On the second page of the LO version, the beginning text is displaced down the page instead of being at the top of the page and pushed too far to the left of the page.
- On the second page of the LO version, text after the section heading beginning "convenient data sharing..." is missing. 
- LO has added a fourth blank page which doesn't exist in the original.
Comment 5 Timur 2018-09-03 15:38:49 UTC
Bugzilla is not "document based", like "this document is scrambled". 
Bugzilla is "issue based", so a single issue must be pointed at, after a search for not being a duplicate. 

So let's focus here on a single issue:
- On the first page of the LO version, the blue background behind the "save on your banking..." section overlies the text instead of being a background.
and rephrase:
"Solid fill in 2007 DOCX text box shape imported separately and overlies the text".
Looks like regression. Was fine in 4.3.7.2.

Point 2 is also valid observation, but for the different bug. Point 3 is somewhat valid, because if saved in MSO without keeping compatibility it's pushed from 2nd to 3rd page. Point 4 is not relevant here. 
Original 2007 DOCX has it's problems, if saved in MSO it looks different and has 4 pages.
Comment 6 Xisco Faulí 2018-09-04 14:58:35 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d379d18666aa42031359ca8eb34b0021960347ae

author	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-18 11:57:31 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-18 12:09:15 +0200
commit	d379d18666aa42031359ca8eb34b0021960347ae (patch)
tree	d0324e2297be256e8c291cd6e17676f68f9f072d
parent	8e67a7796f598de2f11b694542bccb48343f0d9a (diff)
oox: import WPS shape with text as shape with textbox

Bisected with: bibisect-44max

Adding Cc: to Miklos Vajna
Comment 7 Xisco Faulí 2018-09-04 14:59:02 UTC
@Justin Luth, I thought you could be interested in this issue...
Comment 8 Xisco Faulí 2018-09-04 15:02:09 UTC
Actually, this is a dupe of bug 107428

*** This bug has been marked as a duplicate of bug 107428 ***