Bug 119657 - HELP: Add informations about changing left paragraph indent of the ruler with CTRL
Summary: HELP: Add informations about changing left paragraph indent of the ruler with...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures Rulers
  Show dependency treegraph
 
Reported: 2018-09-03 06:43 UTC by Dieter
Modified: 2021-01-23 10:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
My submission for bug 119657 HELP: Add informations about changing left paragraph indent of the ruler with CTRL (238.26 KB, application/vnd.oasis.opendocument.text)
2018-12-26 18:21 UTC, Mark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter 2018-09-03 06:43:36 UTC
In the documentation about the ruler [1] there is no information about the possibility to change the left paragraph indent by using the ctrl-key and the bottom left triangle.

See also the discussion in bug 119076.

(1] https://help.libreoffice.org/6.2/en-US/text/swriter/guide/ruler.html?DbPAR=WRITER#bm_id8186284
Comment 1 Bernd Wechner 2018-09-05 00:10:08 UTC
I can certainly confirm that mention of CTRL+drag is missing from this page (of documentation) and that it is a very useful thing to know!

Moreover it says "You can also double-click anywhere on the horizontal ruler, and adjust the indents in the Paragraph dialog." without mentioning that doing so creates a tab stop too!

Personally I find it odd to refer to these drag handles as "triangles" as well, when they are not (even) triangles. I've struggled to find what Microsoft call theirs because their documentation is so lame.

Of course, they way they do it is they split that drag handle into a top and bottom part and if you drag the bottom part it's equivalent to what LibreOffice Writer does, and if you drag the top part it's the equivalent to what LibreOffice Writer does when CRTL is held down. In short they provide a visual cue on screen to explore and aid in discovery.
Comment 2 Mark 2018-12-26 18:21:08 UTC
Created attachment 147848 [details]
My submission for bug 119657 HELP: Add informations about changing left paragraph indent of the ruler with CTRL

My first submission bug fix for Libre Office document ion. Please go easy of the flaming.
Comment 3 Olivier Hallot 2019-01-25 19:25:10 UTC
Thanks for the addition

some remark

* more info on rulers: https://help.libreoffice.org/6.2/en-US/text/shared/02/13020000.html?&DbPAR=WRITER&System=UNIX, possibly covering the bug subject. A 2-way link between the 2 help pages can be enough.
Comment 4 Dieter 2021-01-15 04:35:48 UTC
(In reply to Olivier Hallot from comment #3)
> A 2-way link between the 2 help pages can be enough.

I agree
Comment 5 sdc.blanco 2021-01-15 11:18:40 UTC
(In reply to Dieter from comment #4)
> I agree

At present the following two help pages do not have "links" (e.g., in "Related Topics") to each other.  

Do I understand correctly that each page should have a link to the other in "Related topics"? 

https://help.libreoffice.org/7.2/en-US/text/shared/02/13020000.html (Setting Indents, Margins, and Columns)

https://help.libreoffice.org/7.2/en-US/text/swriter/guide/ruler.html  (Using Rulers)
Comment 6 Dieter 2021-01-15 11:21:13 UTC
(In reply to sdc.blanco from comment #5)
> Do I understand correctly that each page should have a link to the other in
> "Related topics"? 

Yes, I understand comment 3 from Olivier in that way.
Comment 7 sdc.blanco 2021-01-15 11:28:04 UTC
Thanks Dieter.  If you have noticed the need for other small "repairs" on those two pages, then please let me know, and I can try to include them in the patch.
Comment 8 Dieter 2021-01-15 11:36:54 UTC
(In reply to sdc.blanco from comment #7)
> Thanks Dieter.  If you have noticed the need for other small "repairs" on
> those two pages, then please let me know, and I can try to include them in
> the patch.

The original idea in comment 0 was to have an information about the use of ctrl-key, like the description in https://help.libreoffice.org/7.2/en-US/text/shared/02/13020000.html: "In order to change the left indent starting with the second line of a paragraph, hold down the Ctrl key, click the triangle on the bottom left, and drag it to the right."

So a link might be sufficient, although it would be more convenient, if this information is part of: https://help.libreoffice.org/7.2/en-US/text/swriter/guide/ruler.html

Please decide on your own.
Comment 9 Commit Notification 2021-01-15 13:27:52 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/fc682e9a8b7d6d6438668fb61304460f35002b3d

tdf#119657  add related topics links to help about rulers and margins
Comment 10 sdc.blanco 2021-01-15 13:53:10 UTC
@Dieter, thanks for explanation.  Have added the links between the two pages, and found a way to include the "tip" information ("In order to change...") from "Setting Indents, Margins, and Columns" in the "Using Rulers" page.  

So I will close this ticket as FIXED, but needed corrections can be sent here.
Comment 11 Dieter 2021-01-23 10:26:48 UTC
Thanks for fixing that issue in https://help.libreoffice.org/7.2/en-US/text/swriter/guide/ruler.html

=> VERIFIED FIXED