Bug 119671 - UI: Add "Calculate All" to menu "Data\Calculate"
Summary: UI: Add "Calculate All" to menu "Data\Calculate"
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.2.0
Keywords:
: 119971 (view as bug list)
Depends on:
Blocks: Main-Menu Calculate
  Show dependency treegraph
 
Reported: 2018-09-03 17:17 UTC by Oliver Brinzing
Modified: 2018-09-20 03:00 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
lo 6.1.1 screenshot menu data calcuate (108.61 KB, image/png)
2018-09-04 16:18 UTC, Oliver Brinzing
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Brinzing 2018-09-03 17:17:44 UTC
currently only "Recalculate F9" is available in menu "Data\Calculate".
a user, who needs a full hard recalc has to know about the shortcut keys:
Shift+Ctrl+F9.

from LO Online Help:
Recalculates all changed formulas. If AutoCalculate is enabled, the Recalculate command applies only to formulas like RAND or NOW. Press F9 to recalculate.
Press Shift+Ctrl+F9 to recalculate all formulas in the document.
After the document has been recalculated, the display is refreshed. 
All charts are also refreshed.
The Add-In functions like RANDBETWEEN currently cannot respond to the Recalculate command or F9. Press Shift+Ctrl+F9 to recalculate all formulas, including the Add-In functions.
Comment 1 m.a.riosv 2018-09-03 21:09:13 UTC
It is already implemented with 6.0.7 and 6.1

Menu/Data/Calculate/Recalculated hard.
Comment 2 Oliver Brinzing 2018-09-04 16:18:30 UTC
Created attachment 144671 [details]
lo 6.1.1 screenshot menu data calcuate

>It is already implemented with 6.0.7 and 6.1

it's possible to add "Recalculate Hard" via "Tools/Customize.../Menus"
but it is not existent in the standard configuration.
Comment 3 Heiko Tietze 2018-09-05 06:20:47 UTC
Eike, Moggi: was there a reason to not have this function in the menu? Something like potential damage to data.
Comment 4 m.a.riosv 2018-09-05 08:02:51 UTC
Forgive Oliver, I have it added in both version, so I though it was already included.

If I remember fine, it was implemented by Samuel years ago, but was reverted. Kohei was against because there was the intention to avoid their need.
Comment 5 Xisco Faulí 2018-09-05 10:52:08 UTC
(In reply to m.a.riosv from comment #4)
> Forgive Oliver, I have it added in both version, so I though it was already
> included.
> 
> If I remember fine, it was implemented by Samuel years ago, but was
> reverted. Kohei was against because there was the intention to avoid their
> need.

@Kohei,
I thought you could have an opinion in this issue...
Comment 6 Oliver Brinzing 2018-09-05 16:58:42 UTC
my intention was to make it easier for users to deal with
situations as - for example - described in issue:

[Bug 119623] Lonely SUM formula fails to update, and thus
can lead to a treacherously wrong result
https://bugs.documentfoundation.org/show_bug.cgi?id=119623

where - for whatever reason - "AutoCalculate" and
"Recalculate F9" will not work.

btw: in writer we have: "Menu Tools/Update/Update All"
Comment 7 Cor Nouws 2018-09-12 15:38:28 UTC
I support the request,
Cor
Comment 8 Heiko Tietze 2018-09-13 06:47:47 UTC
We discussed the request in the design meeting and don't see any reason why to not add the function. Patch is here https://gerrit.libreoffice.org/#/c/60422/
Comment 9 Commit Notification 2018-09-13 10:33:25 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d8f8fa33f477ddb445ef7a89590ad2314e3f7cca

tdf#119671 - UI: Add "Calculate All" to menu "Data\Calculate"

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 BogdanB 2018-09-15 18:52:52 UTC
Data - Calculate - Recalculate Hard (Control + Shift + F9) is available on this version.

Version: 6.2.0.0.alpha0+
Build ID: e005ab5d40d358adb75a64e140d46f4bf605647d
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-09-15_02:08:38
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 11 perie_gut 2018-09-20 03:00:03 UTC
*** Bug 119971 has been marked as a duplicate of this bug. ***