Download it now!
Bug 119677 - In Calc Function 'Follow Hyperlink' does not Work Correctly in Several Cases
Summary: In Calc Function 'Follow Hyperlink' does not Work Correctly in Several Cases
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink-Calc
  Show dependency treegraph
 
Reported: 2018-09-03 21:23 UTC by Harald Koester
Modified: 2018-10-29 17:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example Spread Sheet (14.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-09-03 21:23 UTC, Harald Koester
Details
Table with error conditions and error patterns (16.57 KB, application/vnd.oasis.opendocument.text)
2018-10-17 13:48 UTC, Harald Koester
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2018-09-03 21:23:19 UTC
Created attachment 144647 [details]
Example Spread Sheet

Calc offers the possibility to insert hyperlinks into spread sheets and open the links either with a left mouse Click or with Ctrl-Click. I tested this function for several cases and found some cases where the function is erroneous. In order to reproduce these issues, open the attachment and test some cases within the spread sheet.

These error patterns occur alone or together:
(1) The tip with the hint how to follow a hyperlink and with the URL of the hyperlink is not displayed.
(2) In the tip only the URL is displayed. The hint how to follow the link (“Ctrl-click to follow hyperlink”) is not displayed.
(3) The appearance of the mouse pointer changes the appearance to the symbol with the hand also if Ctrl is not pressed.
(4) Crtl-Click does not open the hyperlink in your browser.
Comment 1 Regis Perdreau 2018-09-03 21:55:17 UTC
I confirm that the tip is not always completely displayed and that links not always working as cursor in a shape or in cell.
But bug or feature, need may be confirmation.




Version: 6.0.3.2
Build ID: 1:6.0.3-0ubuntu1
Threads CPU : 4; OS : Linux 4.15; UI Render : par défaut; VCL: x11; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 2 Harald Koester 2018-09-04 09:33:11 UTC
For me the behaviour is not OK. But this can also be assessed differently. From my point of view I can't provide more information. Hence set status back to UNCONFIRMED.
Comment 3 Buovjaga 2018-09-24 18:54:27 UTC
You have four issues here. We need one issue per report.
In your other reports you list some issues that occur in multiple applications. Issues like these could be reported against component LibreOffice and then all the affected applications mentioned in the summary.

By "cursor is in a x" I take it you mean "when in text edit mode in x".
Comment 4 Harald Koester 2018-09-25 14:15:16 UTC
(In reply to Buovjaga from comment #3)
> You have four issues here. We need one issue per report.
> In your other reports you list some issues that occur in multiple
> applications. Issues like these could be reported against component
> LibreOffice and then all the affected applications mentioned in the summary.

In the initial report I only listed the error patterns and not the cases when they occur. These are listed in the attached document. There are 14 cases listed. If I  follow your demand I had to write 14 bug reports. I think this is exaggerated. I also think, that there are close relationships at least between some of the cases. Hence a developer has to keep the other cases in mind, when he fixes this bug(s). I think this is more difficult, if the cases are distributed on several bug reports.


> By "cursor is in a x" I take it you mean "when in text edit mode in x".

I only checked the behaviour with Edit Mode enabled. I think some of the bugs may also occur if Edit Mode is off.
Comment 5 Usama 2018-10-12 11:43:16 UTC
Hello,
Thank you for reporting this. Your efforts to improve this software are appreciated. 


1. If a Cell/Shape/Text box is in editing mode, the link tip should still appear.

this could be confusing if you check how comments work. Even in edit mode inside a cell you can still see a comment if you hover on a cell with a comment. If it's a bug or not it's different story.

2. Regarding the  "string “Ctrl-click to follow hyperlink...” is not displayed. is apparently a real simple bug candidate. When I press Ctrl and click on a link it opens.

I think you may want to open a different bug for the later as the case is more clear and. I would be happy to open it for you if you don't mind.

Regards,
Usama
Comment 6 Harald Koester 2018-10-17 13:48:07 UTC
Created attachment 145780 [details]
Table with error conditions and error patterns
Comment 7 Harald Koester 2018-10-17 14:15:40 UTC
(In reply to Usama from comment #5)

> 2. Regarding the  "string “Ctrl-click to follow hyperlink...” is not
> displayed. is apparently a real simple bug candidate. When I press Ctrl and
> click on a link it opens.
> 
> I think you may want to open a different bug for the later as the case is
> more clear and. I would be happy to open it for you if you don't mind.

In order to make this bug(s) more transparent I created a table with the bug conditions and the error patterns, which occure with each bug condition (attachment 145780 [details]). The pattern "Tip is not displayed" occurs three times in this table. Together with this pattern always the pattern "Hyperlink does not work" occurs. So if only the pattern "Tip is not displayed" is fixed, it looks like that the hyperlink works, but it is not the case. I think that would be worse than before. 

So I don't really see a possibility to split this bug(s) into different reports (see also my comment 4).
Comment 8 Buovjaga 2018-10-29 17:16:28 UTC
Ok, Usama and me split this up so I will close.