Download it now!
Bug 119687 - UI Writer: Enhancement request - scaling of margin for comments
Summary: UI Writer: Enhancement request - scaling of margin for comments
Status: RESOLVED DUPLICATE of bug 73953
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-04 10:48 UTC by Lars Jødal
Modified: 2018-09-04 13:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2018-09-04 10:48:01 UTC
Description:
Writer has the useful feature of adding comments, which are shown in an extra margin. However, the size of this margin is fixed. For a text with many and/or long comments (e.g. a collaborative project with comments from several people), the comment margin can become quite messy. At the same time, today's wide screens typically allow plenty of room for a wider comment margin.

It is requested to allow the user to scale the margin for comments. This would allow the user to change the margin to his or her preference. 
The scaling could be implemented as a moveable marker, in the same way as text margins can be changed, possibly supplemented with a point under Settings.


Steps to Reproduce:
1. Start Writer.
2. Write som text.
3. Add a comment by Insert -> Comment (or Alt-Ctrl-C)

Actual Results:
Comment is shown in right margin with a fixed width, which apparently cannot be changed.

Expected Results:
Width of comment margin should be adjustable, e.g. by use of mouse in the ruler at the top of the screen (just as text margin is adjustable here). 


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Dieter 2018-09-04 13:07:09 UTC
There are some bugs with very similar proposals like bug 38295, bug 73953 and bug 95958. So please chekc, if one of the bugs fits with your idea.
Comment 2 Lars Jødal 2018-09-04 13:31:24 UTC
I have to agree, my enhancement suggestion is very similar to those of bug 73953 and bug 95958 (and but 97341). I am marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 73953 ***