Bug 119711 - contextmenu Chart: sheettab.xml
Summary: contextmenu Chart: sheettab.xml
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2018-09-05 21:16 UTC by andreas_k
Modified: 2018-11-01 22:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Left 6.1 right change request (60.29 KB, image/png)
2018-09-05 21:16 UTC, andreas_k
Details
sheettab (104.62 KB, image/png)
2018-09-07 13:53 UTC, andreas_k
Details
sheettab (139.10 KB, image/png)
2018-09-07 16:21 UTC, andreas_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-09-05 21:16:47 UTC
Created attachment 144705 [details]
Left 6.1 right change request

Remove
------
cut
copy
paste

should be removed OR add also the paste submenu from cell.xml The reason is simple. You can't copy and past a sheettab this three actions will be a result of the cell you have selected so it's the same result than right click on the cell which mean also paste special items should be shown.

I would extend the insert sheet secton to the items from menubar -> sheets

add
---
Insert Sheet from File
Link to External Data

rearrange
---------
- separator between insert and rename/delete/move section (cause insert has now 3 entries)
- tab color and sheet events are grouped in menubar -> sheets so it should be together here also
- protect Sheet, View Grid Lines, Hide Sheet, Show Sheet together in one group
Comment 1 Heiko Tietze 2018-09-07 12:52:44 UTC
(In reply to andreas_k from comment #0)
> Remove
> ------
> cut
> copy
> paste

Okay.
 
> add
> ---
> Insert Sheet from File
> Link to External Data

Disagree here. Insert from file is available after Insert Sheet. And the link to external data is not used frequently.
 
> rearrange
> ---------
> - separator between insert and rename/delete/move section (cause insert has
> now 3 entries)

Doesn't apply with my comments. "Move or Copy" could go on top like Copy/Paste.

> - tab color and sheet events are grouped in menubar -> sheets so it should
> be together here also

Together yes but also on the bottom of the menu. 

> - protect Sheet, View Grid Lines, Hide Sheet, Show Sheet together in one
> group

View Grid Lines is a different function than the other.
Comment 2 andreas_k 2018-09-07 13:53:17 UTC
Created attachment 144739 [details]
sheettab

like this
Comment 3 Heiko Tietze 2018-09-07 15:35:45 UTC
(In reply to andreas_k from comment #2)
> like this

Yes. Select All Sheets does not fit into this section. Option a) under Move/Copy followed by a separator, b) to the bottom, and c) with protect/hide. The View Grid Lines item feels a bit lonely in its own section.
Comment 4 andreas_k 2018-09-07 16:21:19 UTC
Created attachment 144741 [details]
sheettab
Comment 5 Heiko Tietze 2018-09-07 16:59:27 UTC
+1
Comment 6 BogdanB 2018-09-07 17:22:36 UTC
(In reply to andreas_k from comment #4)
> Created attachment 144741 [details]
> sheettab

In the last screenshot, View grid and Hide Sheet are in the left menu at diferent positions and with separator. In the right position they are together. This is not consistent.
Comment 7 andreas_k 2018-09-07 21:41:36 UTC
> In the last screenshot, View grid and Hide Sheet are in the left menu at
> diferent positions and with separator. In the right position they are
> together. This is not consistent.

Thanks for the feedback. The issue is that view grid lines are an "visible" thing it change how the tab will look like it "hide" the grid. Hide sheet is also kind of "visible" option it hide the sheet.

Do you have an better idea for grouping cause the main issue is, that I don't want to have groups with only one item.