Bug Hunting Session
Bug 119712 - The text boxes with "To Page" anchor disappear if the text direction in page format is set to "right-to-left"
Summary: The text boxes with "To Page" anchor disappear if the text direction in page ...
Status: RESOLVED DUPLICATE of bug 117938
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: RTL-Textbox
  Show dependency treegraph
 
Reported: 2018-09-05 21:26 UTC by Mahmoud Alnaanah
Modified: 2018-09-07 10:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example to illustrate the bug where text box with "To page" anchor disappear if page text direction changed to "right-to-left" (9.32 KB, application/vnd.oasis.opendocument.text)
2018-09-05 21:28 UTC, Mahmoud Alnaanah
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mahmoud Alnaanah 2018-09-05 21:26:22 UTC
Description:
In Writer, the text boxes with "To Page" anchor disappear if the text direction in page format is set to "right-to-left"

I use Libreoffice Version 6.0.3.2 Kubuntu 18.04.



Steps to Reproduce:
1- Enable "Complex text layout" from language settings. (in my case it is Arabic Jordan).
2- Create new text box and put some text in it.
3- Set the anchor of the text box to "To Page".
4- In Format>Page>Page. Set the "Text direction" to "Right-to-Left".
5- The text box will disappear.

Actual Results:
The text box will disappear.

Expected Results:
Text box should remain.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Mahmoud Alnaanah 2018-09-05 21:28:37 UTC
Created attachment 144706 [details]
Example to illustrate the bug where text box with "To page" anchor disappear if page text direction changed to "right-to-left"
Comment 2 Dieter Praas 2018-09-06 12:51:25 UTC
I confirm it with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL
Comment 3 Xisco Faulí 2018-09-07 10:11:06 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=689cead9e0837dc932e3a4cd765f7d319b529018, which is the same as in bug 117938.
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 117938 ***