Bug Hunting Session
Bug 119737 - Wrong item Formula in drop-down menu Insert on Groupedbar in Writer
Summary: Wrong item Formula in drop-down menu Insert on Groupedbar in Writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.0.1
Keywords:
Depends on:
Blocks: Notebookbar-Groupedbar
  Show dependency treegraph
 
Reported: 2018-09-06 17:56 UTC by Roman Kuznetsov
Modified: 2018-12-18 00:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-09-06 17:56:28 UTC
Description:
Wrong item Formula in drop-down menu Insert on Groupedbar in Writer.
This item need if I want insert a formula to calculating in Writer cells.
But it is active if cursor not in table!

And if I want insert Math formula in document, then I can't, because there isn't item Insert Math Formula in menu Insert

Steps to Reproduce:
1. Change GUI to Groupedbar in Writer
2. Select Insert->Formula - will show formula bar for insert calculating formula in table
3.

Actual Results:
we have wrong item Formula in drop-down menu Insert on Groupedbar in Writer, when cursor is not in table and don't have item Insert Math Formula

Expected Results:
we don't have item Formula in drop-down menu Insert on Groupedbar in Writer, when cursor is not in table and we have item Insert Math Formula


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2018-10-01 17:25:58 UTC
Yep.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: d357ea1d1ff95cb5ce2ee6b4828afa2484707256
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on 28 September 2018
Comment 2 Commit Notification 2018-12-11 08:05:03 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/11e6b7832465e37b3dc6f14f175e870b25ee4d19%5E%21

tdf#119737 Wrong item Formula in drop-down menu Insert groupedbar

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2018-12-11 10:39:47 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9cb7512cb7745e03c402dfaeba470465af931135%5E%21

tdf#119737 Wrong item Formula in drop-down menu Insert groupedbar

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.