Download it now!
Bug 119757 - Dialogs like Format page/ format header open with a annoying delay in LibO6.2 (again)
Summary: Dialogs like Format page/ format header open with a annoying delay in LibO6.2...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: Page-Style-Dialog
  Show dependency treegraph
 
Reported: 2018-09-08 11:57 UTC by Telesto
Modified: 2018-10-19 09:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-09-08 11:57:41 UTC
Description:
Bug 118731 reappeared. Dialogs like Format page/ format header open with a annoying delay in LibO6.2 (again) 




Steps to Reproduce:
Steps to Reproduce:
1. Open Writer
2. Format -> Page

Actual Results:
Really slow loading

Expected Results:
Fast as before


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: 22f49d10c001f9d62e3783872bc7e53a902265a3
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-08_03:56:10
Locale: nl-NL (nl_NL); Calc: threaded

but not in
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 0a1a4ffb4f87adff7fbbbc60202b6a0e42fedd0c
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-08_23:17:46
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Roman Kuznetsov 2018-09-08 15:33:26 UTC
Xisco, do we have bisect repo for 6.2?
Comment 2 Telesto 2018-09-08 15:48:50 UTC
(In reply to Roman Kuznetsov from comment #1)
> Xisco, do we have bisect repo for 6.2?

https://gerrit.libreoffice.org/#/admin/projects/bibisect-win32-6.2

The issue rather new. Introduced 3 or 4 days ago
Comment 3 Telesto 2018-09-08 15:50:17 UTC
Adding bug 119756 to see also. Same range, so perhaps related
Comment 4 raal 2018-09-08 19:47:06 UTC
I can confirm with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 9a9b81c7212fa6a6762246593acf3f1950677a22
CPU threads: 1; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-07_23:40:38
Comment 5 Xisco Faulí 2018-09-10 09:06:02 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7cb3e475f2fb0162c7290414509de4fb8fe57e30

author	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-06 14:04:25 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-07 20:27:01 +0200
commit	7cb3e475f2fb0162c7290414509de4fb8fe57e30 (patch)
tree	ecd3e4dedd2c171991700a4294c410d17782179c
parent	334df91c6e464fe6434500f63e2fb12438722845 (diff)
WIN add SalGraphics* to WinFontInstance

Bisected with: bibisect-win32-6.2

Adding Cc: to Jan-Marek Glogowski
Comment 6 Jan-Marek Glogowski 2018-10-18 19:49:59 UTC
If this is a duplicate of tdf#119756 it should be fixed too. Please reopen, if the bug still exists.
Comment 7 Xisco Faulí 2018-10-19 09:55:34 UTC
it opens the page dialog within 2 seconds...

Version: 6.2.0.0.alpha0+
Build ID: 3f9c477929c261a8862411c00153e4c7d0d0ae7c
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); Calc: threaded