Bug 119914 - FILEOPEN Adjacent tables in DOC mostly overlap
Summary: FILEOPEN Adjacent tables in DOC mostly overlap
Status: RESOLVED DUPLICATE of bug 106840
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc
Depends on:
Blocks: DOC-Tables DOC-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2018-09-16 23:05 UTC by Aron Budea
Modified: 2020-04-23 12:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOC (32.50 KB, application/msword)
2018-09-16 23:05 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-09-16 23:05:14 UTC
Created attachment 144922 [details]
Sample DOC

This is the same as bug 117134, but the document is in DOC format this time.

The attached DOC contains two tables, right below one another. The first one is a floating table (text wrapping set to: Around), there's an empty line between the tables, but it slides up next to the first table because of that.
See attachment 141509 [details] for how it looks in Word.

In Writer the two tables (the first is imported inside a frame) mostly overlap. Similarly to bug 117134, just slightly differently.
This is a case where having a setting mentioned in bug 117132 could be useful.

Observed using LO 6.1.1.2 & 4.4.0.3 / Windows 7.
Tables don't overlap in 4.0.0.3.

This is likely not a clear-cut regression, nevertheless, finding the commit where it started would be nice.
Comment 1 Aron Budea 2018-09-17 04:40:51 UTC
The overlap started with the following commit (plus ce0f4825730a0f96ca5369a7d07982ea073901fb, which fixed a compilation issue), bibisected using repo bibisect-41max.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4e07258cbd1f4fb16d6ce2174fb5c74c3b36da33
author		Chen ZuoJun <zjchen@apache.org>	2012-10-08 12:21:52 +0000
committer	Xisco Fauli <anistenis@gmail.com>	2013-04-14 17:52:34 +0200

"#i119466# Doc file loaded by AOO, table with incorrect text wrapping property."

A piece of comment from the code:
//#i119466 mapping "Around" wrap setting to "Parallel" for table
Comment 2 QA Administrators 2019-10-11 02:37:08 UTC Comment hidden (obsolete)
Comment 3 Aron Budea 2019-10-14 01:33:26 UTC
Still buggy in 6.4.0.0.alpha0+ (bb6bcabda53dbd64dda43f09fab9f4ad6f34eba6).
Comment 4 Justin L 2020-04-23 12:48:29 UTC
Since LO doesn't know how to "wrap" a table around floating objects, I wouldn't consider this a DOC bug.

*** This bug has been marked as a duplicate of bug 106840 ***