Bug Hunting Session
Bug 120009 - page break indicators do not show unless print preview was started once.
Summary: page break indicators do not show unless print preview was started once.
Status: RESOLVED DUPLICATE of bug 124983
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Page-Break
  Show dependency treegraph
 
Reported: 2018-09-20 13:46 UTC by miksi
Modified: 2019-10-07 13:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description miksi 2018-09-20 13:46:03 UTC
Description:
The indicator lines showing page break do not show up unless the print preview was run.

Steps to Reproduce:
1. create new document
2. enter data in cells
3. notice no page break indicators showing
4. click print preview symbol
5. exit print preview
6. page break indicators are now visible

Actual Results:
The page break indicators are not visible until step 6.

Expected Results:
The page break indicators should be visible immediately.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 BogdanB 2018-09-20 15:42:19 UTC Comment hidden (obsolete)
Comment 2 miksi 2018-09-21 10:26:11 UTC
(In reply to BogdanB from comment #1)
> On Linux, I tested this case on 2 versions with 2 steps on Writer:
> 
> Maybe you should try a newer version of Libre Office. To test it. For me
> 6.1.1.0.0 and 6.2 works perfect about this subject.



My bug report is for CALC, not Writer.
Comment 3 BogdanB 2018-09-21 13:57:20 UTC
I tested now on Windows 10. Confirm it. 

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 3208fcb3a36d75d6290d9c548430682f153b09db
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_22:43:20
Locale: ro-RO (ro_RO); Calc: threaded
Comment 4 Xisco Faulí 2018-10-04 15:55:52 UTC
I can reproduce it back to


LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

I'm wondering if this is the expected behavior... Adding UX team to the loop
Comment 5 BogdanB 2018-10-04 19:25:12 UTC
Would be very nice to have this. You can now from the first look if the page fits in one page or more, like on xls.
Comment 6 Heiko Tietze 2018-10-05 10:22:36 UTC
From UX POV the user is always right - or maybe not always but in this case :-).

However, question is if we can know what constraints the output get when the sheet has not been printed / previewed. It's defined in Format > Page... so I guess we can. And actually it's enough to open and close the page settings to see the margins.
Comment 7 BogdanB 2018-10-05 15:04:11 UTC
(In reply to Heiko Tietze from comment #6)
> From UX POV the user is always right - or maybe not always but in this case
> :-).

Last days I was bibisecting a bug that needed those line to see if they are ok or not, and I needed to PrintPreview in order to see the line. In excel just open the file and you have the lines.

From my point of view this shoulnt be hard to change because LO knows after PrintPreview this info, just have to be calculated before preview. By default.
Comment 8 Xisco Faulí 2018-10-17 14:41:39 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 9 Michael Weghorn 2019-10-07 13:27:50 UTC
This was fixed along with bug 124983.

*** This bug has been marked as a duplicate of bug 124983 ***