Bug 120028 - PPTX import: shape text with multiple columns is unreadable
Summary: PPTX import: shape text with multiple columns is unreadable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.2.0 target:6.0.7 target:6.1.3
Keywords: filter:ooxml
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2018-09-21 08:54 UTC by Miklos Vajna
Modified: 2018-10-19 10:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document. (29.75 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-09-21 08:54 UTC, Miklos Vajna
Details
Font color reproducer. (29.16 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-10-01 14:38 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2018-09-21 08:54:04 UTC
Created attachment 145086 [details]
Reproducer document.

Steps to reproduce:

1) Open the attached document

2) Observe the distribution of text in the shape.

Expected result: text is distributed in 4 columns.

Actual result: text is in a single column, and has a small enough font size (due to shrink-to-fit) that it's unreadable.
Comment 1 Commit Notification 2018-09-21 11:31:52 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aef569ed83a3ccc02639e5b2a1c7cc131ba262fc

tdf#120028 PPTX import: map shapes with multiple columns to table shapes

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 2 Miklos Vajna 2018-09-21 16:07:53 UTC
There are still a few minor problems remaining, let's keep this bug open till I get to fix those as well.
Comment 3 Commit Notification 2018-09-21 17:58:24 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c8b2849d140677f7b35523096eb2bc715b3dc507

Related: tdf#120028 PPTX import: fix font size of multi-col shape text

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Luke 2018-09-25 19:33:33 UTC
*** Bug 90140 has been marked as a duplicate of this bug. ***
Comment 5 Luke 2018-09-28 17:29:19 UTC
Miklos,
Does your remaining issues include the issue exposed by Bug 90140,  attachment 114222 [details]? The center format is lost and bullet list is added. If not, should I file a bug report?
Comment 6 Miklos Vajna 2018-10-01 08:16:17 UTC
No, please open a separate bug for that. I'll close this bug soon to avoid confusion.
Comment 7 Miklos Vajna 2018-10-01 14:38:15 UTC
Created attachment 145294 [details]
Font color reproducer.

I attach an other subset of the original complex document, this one focuses on the part that some font colors are wrong (only in this table shape case).
Comment 8 Commit Notification 2018-10-02 10:34:47 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=800bf1071a30955ff70373b2fb5886eadce59dee

Related: tdf#120028 PPTX import: fix font color of multi-col shape text

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2018-10-02 19:04:05 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f1fb474694876bc4ffeb552dcc7bed8f32cd221&h=libreoffice-6-0

tdf#120028 PPTX import: map shapes with multiple columns to table shapes

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-10-02 19:05:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ff28de400ecf0e367d98a58285f3f82a8e85df6f&h=libreoffice-6-1

tdf#120028 PPTX import: map shapes with multiple columns to table shapes

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Timur 2018-10-04 08:12:18 UTC
This fix has multiple effects on examples from bug 90140 so I reopened that bug:
- bullet list is added
- center format is lost 
- font color is different
- for 3 columns, different size that results in different look

There's also bug 120297 for roundtrip.
Comment 12 Timur 2018-10-18 07:26:37 UTC
Testing with libo-master~2018-10-17_01.54.59_LibreOfficeDev_6.2.0.0.alpha0_Win_x86 as seen in attachment 145798 [details], the look is somehow fixed now. 
What remains is the issue with 3 columns that can be tested with PPTX attachment 145366 [details].
Miklos, please comment whether that belongs here or in a new bug.
Comment 13 Miklos Vajna 2018-10-18 09:43:37 UTC
Let's deal with that in a new bug, please.