Bug 120108 - Wrong wrap optimal icon in Karasa Jaga, elementary, Breeze/Sifr, Tango/Galaxy and Colibre
Summary: Wrong wrap optimal icon in Karasa Jaga, elementary, Breeze/Sifr, Tango/Galaxy...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Icon-Theme-Sifr Icon-Theme-Breeze Icon-Theme-Tango Icon-Theme-Colibre Icon-Theme-KarasaJaga Icon-Theme-Elementary
  Show dependency treegraph
 
Reported: 2018-09-25 05:12 UTC by Rizal Muttaqin
Modified: 2018-10-30 03:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrap optimal in Breeze icon (20.55 KB, image/png)
2018-09-25 05:13 UTC, Rizal Muttaqin
Details
Wrap optimal in Colibre icon (21.12 KB, image/png)
2018-09-25 05:13 UTC, Rizal Muttaqin
Details
Wrap optimal in elementary icon (20.63 KB, image/png)
2018-09-25 05:13 UTC, Rizal Muttaqin
Details
Wrap optimal in Karasa Jaga icon (21.79 KB, image/png)
2018-09-25 05:14 UTC, Rizal Muttaqin
Details
Wrap optimal in Tango (inherited from Galaxy) icon (21.41 KB, image/png)
2018-09-25 05:14 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2018-09-25 05:12:32 UTC
Description:
Steps to Reproduce:
1. Open Writer
2. Insert a shape
3. Right click on the shape -> Wrap -> select Optimal Page Wrap
4. Right click on the shape again -> select Edit ..

Current optimal icon use wrap after/wrap right

Actual Results:
Wrong wrap optimal icon

Expected Results:
Right wrap optimal icon


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: id-ID (id_ID.UTF-8); Calc: group threaded
Comment 1 Rizal Muttaqin 2018-09-25 05:13:12 UTC
Created attachment 145148 [details]
Wrap optimal in Breeze icon
Comment 2 Rizal Muttaqin 2018-09-25 05:13:34 UTC
Created attachment 145149 [details]
Wrap optimal in Colibre icon
Comment 3 Rizal Muttaqin 2018-09-25 05:13:54 UTC
Created attachment 145150 [details]
Wrap optimal in elementary icon
Comment 4 Rizal Muttaqin 2018-09-25 05:14:15 UTC
Created attachment 145151 [details]
Wrap optimal in Karasa Jaga icon
Comment 5 Rizal Muttaqin 2018-09-25 05:14:42 UTC
Created attachment 145152 [details]
Wrap optimal in Tango (inherited from Galaxy) icon
Comment 6 Commit Notification 2018-09-25 06:03:56 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=46d781553e0ab0b55363d9ec57a6487b0f7caa26

tdf#120108 KJ: Update decrease indentation & wrap icon; add LICENSE

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Julien Nabet 2018-09-26 06:47:53 UTC
First commit about Karasa is https://cgit.freedesktop.org/libreoffice/core/commit/?id=a06954bf5b100c9433b4e1dbcdcf8ab2df2763a1, 2018-05-22.
So it's not inherited from OOo, it's only from 6.2.0
If so, this one should be put to fixed, shouldn't it?
Comment 8 Rizal Muttaqin 2018-09-26 06:54:19 UTC
(In reply to Julien Nabet from comment #7)
> First commit about Karasa is
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=a06954bf5b100c9433b4e1dbcdcf8ab2df2763a1, 2018-05-22.
> So it's not inherited from OOo, it's only from 6.2.0
> If so, this one should be put to fixed, shouldn't it?

Karasa Jaga in the first place is always follow Galaxy as the reference. So, this bug actually happen in Galaxy, inheritted from Ooo. Another thing that it affect other icons too since they follow also Galaxy.
Comment 9 Julien Nabet 2018-09-26 07:02:33 UTC
(In reply to Rizal Muttaqin from comment #8)
> ...
> Karasa Jaga in the first place is always follow Galaxy as the reference. So,
> this bug actually happen in Galaxy, inheritted from Ooo. Another thing that
> it affect other icons too since they follow also Galaxy.

Thank you for your quick feedback, I understand better now. So it needs more patches for other themes + backports at least (only?) for 6.1 branch.
Comment 10 Heiko Tietze 2018-09-26 07:57:39 UTC
I understand the need code-wise that a new variable is needed for this icon. And design-wise that fancy icons have to be created for all themes. Would close this ticket as fixed.
Comment 11 Commit Notification 2018-09-26 14:05:32 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f16835c10435ddafdfe05921eac9b89e488ab8e

tdf#120065 and tdf#120108, Fix wrap elementary icons

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-10-29 19:06:19 UTC
A polite ping to Rizal Muttaqin:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 13 Rizal Muttaqin 2018-10-30 03:40:20 UTC
(In reply to Xisco Faulí from comment #12)
> A polite ping to Rizal Muttaqin:
> Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
> Otherwise, Could you please explain what's missing?
> Thanks

Already fixed for Karasa Jaga and elementary, while other icons need to be changed also. CC Andreas Kainz