Bug 120242 - Impress looses paper size and orientation settings in Print dialogue
Summary: Impress looses paper size and orientation settings in Print dialogue
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.2.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 122166 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2018-10-01 14:44 UTC by bellgardt
Modified: 2019-01-24 12:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
can not reproduce on linux (1.71 MB, video/mp4)
2018-10-01 14:49 UTC, BogdanB
Details
setting first (141.50 KB, image/png)
2018-10-02 05:04 UTC, BogdanB
Details
preview is letter (173.62 KB, image/png)
2018-10-02 05:04 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bellgardt 2018-10-01 14:44:21 UTC
Description:
I am using A4 paper settings in my impress documents (landscape for slides and portrait for notes and handouts (Sample file: https://bugs.documentfoundation.org/attachment.cgi?id=46546 ). 

In LO6.1 after opening the document, paper settings in the print dialog always change to letter. Even when changing back to A4 in the printer properties this setting is mostly ignored (seems not to be totally reproducible).

Also the orientation of the notes is always set to landscape although the notes master is in portrait.

Steps to Reproduce:
1. Open the sample file
2. Go to print dialog
3. Optionally go to printer properties and change page to A4

Actual Results:
Paper size is always letter and (almost every time) can't be changed to A4.
Orientation of notes is landscape.

Expected Results:
Should be A4 from the beginning.
Orientation of notes should be always portrait.
It should be possible to change paper settings in the print properties dialog.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.2.1
Build-ID: 65905a128db06ba48db947242809d14d3f9a93fe

In LO 5.4 and earlier the bug wasn't present.
Comment 1 BogdanB 2018-10-01 14:49:10 UTC
Created attachment 145296 [details]
can not reproduce on linux

I tested on Version: 6.2.0.0.alpha0+. I can NOT reproduce on Linux. See the video.
Build ID: a906b68a9fff30c2af5c03189e59c1952cd3f69f
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-30_19:07:59
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 2 BogdanB 2018-10-02 05:02:34 UTC
confirm on
Version: 6.1.2.1 (x64)
Build ID: 65905a128db06ba48db947242809d14d3f9a93fe
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ro-RO (ro_RO); Calc: group threade

I changed to A4, but the preview shows Letter.


Confirm also on
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 3208fcb3a36d75d6290d9c548430682f153b09db
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-20_22:43:20
Locale: ro-RO (ro_RO); Calc: threaded
Comment 3 BogdanB 2018-10-02 05:04:19 UTC
Created attachment 145311 [details]
setting first
Comment 4 BogdanB 2018-10-02 05:04:46 UTC
Created attachment 145312 [details]
preview is letter
Comment 5 Xisco Faulí 2018-10-03 17:35:35 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=57991f885e60d04e93bf5004d4fdceee7d29f3d8

author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>	2017-12-12 11:32:06 +0300
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-01-23 17:01:31 +0100
commit	57991f885e60d04e93bf5004d4fdceee7d29f3d8 (patch)
tree	b4d98d7051eccf14e569f4df243e7192db5f187f
parent	c73f88de8bc6f892ff1215c5f634ff0bfca04553 (diff)
tdf#91362: Use document paper size for printing slides.
By default for priniting slides we use not default A4, but size provided
in slide properties.

Additinally renamed IsPageSize() -> IsPaperSize(): it is less ambiguous.

Bisected with: bibisect-win32-6.1

Adding Cc: to Vasily Melenchuk
Comment 6 Roman Kuznetsov 2019-01-09 14:13:26 UTC
in 
Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

I can't repro it

but Print dialogue was reworked in 6.3
Comment 7 Xisco Faulí 2019-01-24 11:50:46 UTC
*** Bug 122166 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-01-24 12:45:16 UTC
This is fixed by the work done by Daniel Silva on the new print dialog.
See -> https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=cb443d07d54d6698eff51b5be2c6b56323f10315..bc0146c2ae43256552c276d2dd86291c98556c42

Version: 6.3.0.0.alpha0+
Build ID: 0d46fb02f3f19d11db40b6c5335d78a3894502d7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as RESOLVED FIXED

Unfortunately, the fix can't be backported. We will need to wait until LibreOffice 6.3 is released...